Microsoft System Center Configuration Manager 2007 for Microsoft System Center Operations Manager 2007 管理包用户指南
另请参阅
System Center Configuration Manager 2007 徽标

欢迎使用 Microsoft System Center Configuration Manager 2007 (ConfigMgr) for System Center Operations Manager 2007 管理包。本管理包可以帮助管理员管理和控制 Configuration Manager 2007 服务器。

获取最新的管理包及管理包文档

您可以在 http://go.microsoft.com/fwlink/?LinkId=103233（该链接可能指向英文页面）上找到 Configuration Manager 2007 管理包。

新增功能

有关管理包中的更改的列表，请参阅 Configuration Manager 2007 管理包中的新增功能。

另请参阅

概念

Configuration Manager 2007 管理包监视方案

其他资源

Configuration Manager 2007 管理包概述
部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包疑难解答
Configuration Manager 2007 管理包参考


Configuration Manager 2007 管理包概述

本指南有助于您熟悉 Configuration Manager 2007 管理包的相关部署和技术信息。熟悉这些信息后，您就可以规划管理包部署，了解该管理包具有的功能，以及如何利用这些功能使您的 IT 部门受益。

适用于 Operations Manager 的 System Center Configuration Manager 2007 管理包增强了 Configuration Manager 2007 的监视功能，包括以下几项：

  • 监视所有 Configuration Manager 2007 服务的启动和停止，包括 Windows 管理规范 (WMI)、IIS 管理服务、World Wide Web 发布服务、Windows 部署服务服务器、Trivial FTP Daemon、后台智能传输服务 (BITS) 和 Microsoft SQL Server™ 等关键从属服务。
  • 提醒 Configuration Manager 2007 管理员注意 Configuration Manager 2007 关键状态消息。
  • 监视主站点服务器和管理点上的发现数据记录 (DDR) 、软件清单、硬件清单、状态消息和软件计数的积压。
  • 监视站点系统上的发件箱积压。
  • 监视组件和站点系统角色的运行状况。
  • 监视集合评估、状态消息汇总以及包括站点备份在内的站点维护任务。
  • 监视 SMS Executive 故障转储。
  • 监视 CPU、内存和磁盘这些常规系统资源的使用情况。
  • 监视处理速率。
  • 使用视图和报告来监视许多配置管理器性能计数器的性能趋势。
  • 所有警报的产品知识内容以及处理规则。
  • 检测所有 Configuration Manager 2007 计算机、类和计算机组。
  • Configuration Manager 2007 视图。
  • 显示 Configuration Manager 2007 服务器组的性能、可用性和配置情况的报告。这些链接报告利用了 Systems Center Operations Manager 2007 的性能、配置和可用性趋势增强报告功能。
  • 用于执行 Configuration Manager 2007 管理员控制台应用程序的任务。
  • 包含所有 Configuration Manager 2007 服务器角色和 Configuration Manager 2007 客户端运行状况的“计算机状态”视图。
  • 用于显示层次结构中的站点运行状况及层次结构自身运行状况的“站点层次结构”视图和“站点状态”视图。
  • 重要的 Configuration Manager 2007 服务器和 Configuration Manager 2007 客户端信息的服务发现。
  • Configuration Manager 2007 站点层次结构的拓扑图。
  • 可通过 Configuration Manager 2007 程序属性对分发程序故障配置的 Configuration Manager 2007 警报。

有关监视方案和功能的详细信息，请参阅 Configuration Manager 2007 管理包监视方案。

Configuration Manager 2007 管理包不具备以下功能：

  • 监视 System Management Server (SMS) 1.2、SMS 2.0 或 SMS 2003 或其任何 R2 或 Service Pack 版本。
  • 监视混合的 SMS 环境和配置管理器环境。混合环境是指同时运行所安装的 SMS 1.2、SMS 2.0、SMS 2003 和配置管理器的环境。SMS 2003 子站点可向上报告到 Configuration Manager 2007 父站点。
  • 全面监视运行 Configuration Manager 2007 客户端的 Configuration Manager 2007 仅客户端计算机。
  • 提供现成的监视解决方案，无需任何修改即可管理所安装的任何 Configuration Manager 2007。对于安装的每个 Configuration Manager 2007，其规则阈值有所不同，因此客户需要自定义其规则。

本节内容

Configuration Manager 2007 管理包中的新增功能

建议掌握的 Configuration Manager 2007 管理包知识

支持的 Configuration Manager 2007 管理包配置

另请参阅

概念

开始使用 Configuration Manager 2007 管理包
Configuration Manager 2007 管理包监视方案

其他资源

部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 管理包中的新增功能

适用于 Operations Manager 2007 的 System Center Configuration Manager 2007 管理包可对新功能进行监视，并提供了新的监视机制。不能再对过时的角色和数据源进行监视。

增加了对 Configuration Manager 2007 功能的支持

Configuration Management 2007 管理包增加了对下列 Configuration Manager 2007 功能的监视：

  • 所需的配置管理
  • 操作系统部署
  • 网络访问保护 (NAP)。只有 Configuration Management 2007 Service Pack 1 及其更高版本才支持 NAP 监视功能。
  • 设备管理
  • LAN 唤醒
  • 基于 VSS 的备份
  • 移动客户端；面向分支和 Internet 的基础结构

增加了 SQL Server 可用性监视

现在，配置管理器数据库是从站点服务器来监视的，而不是从 SQL Server 本地监视的。此监视由 SMS Executive 服务的线程 SMS_DATABASE_NOTIFICATION_MONITOR 执行。可使用可用性报告来监视 SQL Server 可用性。

增加了设备管理点可用性监视

设备管理点监视是由 MP 控制管理器执行的，该管理器会向设备管理点发出综合事务，指示它执行自测。然后，该测试的结果将反映为角色的可用性，而这可以通过警报和报告来监视。

增加了分发点可用性监视

分发点可用性监视当前只能用于分支分发点。该角色的可用性由运行在配置管理器客户端上的 BDP 代理来报告。

增加了软件更新点可用性监视

软件更新点可用性反映了角色的运行状况及其与 WSUS 服务器上的更新同步的能力。

增加了状态迁移点可用性监视

状态迁移点监视是由 SMP 控制管理器执行的，该管理器会向状态迁移点发出综合事务，以指示它执行自测。然后，该测试的结果将反映为角色的可用性，而这可以通过警报和报告来监视。

增加了 PXE 服务点可用性监视

PXE 服务点监视是由 PSP 控制管理器执行的，该管理器会向 PXE 服务点发出综合事务，以指示它访问站点数据库。然后，该测试的结果将反映为角色的可用性，而这可以通过警报和报告来监视。

增加了系统健康验证程序可用性监视

系统健康验证程序可用性和运行状况由系统健康验证程序自身动态报告，并可反映其当前的内部运行状态，该状态可通过警报和报告来监视。

增加了网络负载平衡管理点可用性监视

为了对（网络负载平衡）NLB 管理点执行物理和虚拟的管理点监视，已更新了管理点控制管理器。NLB 可用性监视的执行方式与 Configuration Manager 2007 中物理管理点监视的执行方式几乎相同。NLB 中各节点的状态也会受到监视。

增加了组件可用性监视

已检测了许多组件，以生成包含其可用性状态的检测信号。组件可用性问题是通过警报来报告的。

增加了配置管理器任务监视

系统会定期执行集合评估、状态消息汇总和包括备份在内的站点维护任务。站点数据库中的表已扩展，且组件已更新，可报告任务持续时间和状态。现在，系统会报告超过预期执行时间的任务或失败的任务。

更新了收件箱文件数阈值规则

现在，收件箱由管理包性能计数器来监视。过去，这些计数器是通过脚本监视的。

增加了发件箱监视

发件箱监视器会计算发件箱中文件的数量，该数量是由性能计数器来报告的。

更新了从 Operations Manager 控制台启动的 Configuration Manager 2007 任务

在 SMS 2003 中，安装 SMS 管理员控制台时创建的环境变量 SMS_ADMIN_UI_PATH 是用户环境变量，因此，只有该控制台的安装人员才能从操作控制台启动 SMS 任务。在 Configuration Manager 2007 中，此环境变量目前是系统环境变量，此限制已不再存在。以下任务会受到影响：

  • 资源管理器
  • 配置管理器控制台
  • 服务管理器
  • 状态消息
  • 现在，只要存在 ConfigMgr 服务器类的实例，任务窗格中就会提供这些任务。

Configuration Manager 2007 的更新维护模式

现在，下列 Configuration Manager 2007 功能会利用 Operations Manager 维护模式：

  • 备份和恢复
  • 软件更新管理
  • 软件分发

备份和恢复仍执行服务关闭，但由于它会在执行服务关闭之前将 Operations Manager 代理置于维护模式，因此不再需要为此在管理包中提供对服务监视的任何自定义实施。

更新了配置管理器站点层次结构图

Operations Manager (MOM) 2007 中的 SMS 2003 站点层次结构图已更新为可汇总状态。Configuration Manager 2007 管理包的图表

更新了配置管理器的报告

配置管理器包含一些新报告，这些报告侧重于按站点系统角色进行测量的性能计数器和按对象处理计数器进行测量的性能计数器，如与 DDR 相关的计数器。有关新报告的详细信息，请参阅 Configuration Manager 2007 管理包的报告。

删除了配置管理器发送程序角色

Configuration Manager 2007 管理包不再支持远程发送程序。已从管理包中删除了对发送程序角色的支持。

删除了客户端访问点角色

已从 Configuration Manager 2007 中删除了这些角色，并从运行状况资源管理器中删除了对这些角色的监视。

删除了对客户端配置请求发件箱的监视

既然 CCR 不再流过 Configuration Manager 2007 客户端配置请求发件箱（发件箱 ccr.box），管理包就不再支持监视此发件箱。


建议掌握的 Configuration Manager 2007 管理包知识

要部署和操作 Configuration Manager 2007 管理包，建议您掌握以下知识和技能：

  • Operations Manager 2007 监视功能的应用知识。有关 Operations Manager 2007 的详细信息，请访问 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。
  • 了解 Operations Manager 2007 设计架构以及贵公司使用的设计架构。
  • 熟悉有关 System Center Operations Manager 2007 的部署指南中建议采用的管理包部署过程。
  • 配置管理器概念和术语的应用知识。有关 Configuration Manager 2007 的详细信息，请访问配置管理器文档库的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=98803，该链接可能指向英文页面）。
  • 了解 Configuration Manager 2007 的可管理性及其规范。有关维护 Configuration Manager 2007 的详细信息，请参阅有关维护 Configuration Manager 2007 的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102324，该链接可能指向英文页面）和有关可管理性 TechCenter 的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102326，该链接可能指向英文页面）。

另请参阅

概念

Configuration Manager 2007 管理包监视方案

其他资源

部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务


支持的 Configuration Manager 2007 管理包配置

System Center Configuration Manager 2007 和 Systems Center Operations Manager 2007 的要求在其各自的部署指南中有相关说明。Configuration Manager 2007 管理包仅监视 Configuration Manager 2007。

  • 安装 Configuration Manager 2007 管理包之前，必须安装 Operations Manager 2007 MOM 2005 Backward Compatibility Management Pack Update。有关 OpsMgr 2007 MOM 2005 Backward Compatibility Management Pack Update 的详细信息，请访问相关的下载网页（网址为：http://go.microsoft.com/fwlink/?LinkId=101878，该链接可能指向英文页面）。
  • 本 Configuration Manager 2007 管理包不能监视 System Management Server (SMS) 1.2、SMS 2.0 或 SMS 2003。
  • 要监视 SMS 2003，请访问有关用于 Microsoft System Center Operations Manager 2007 的 Microsoft SMS 2003 管理包的网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102297，该链接可能指向英文页面）或有关用于 MOM 2005 的 Systems Management Server (SMS) 2003 管理包的网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102297，该链接可能指向英文页面）。

另请参阅

其他资源

Configuration Manager 2007 管理包概述
Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


部署 Configuration Manager 2007 管理包

本节包含部署、测试和自定义 Configuration Manager 2007 管理包的步骤。

本节内容

开始使用 Configuration Manager 2007 管理包

部署 Operations Manager 2007 代理

测试和试验 Configuration Manager 2007 管理包

自定义 Configuration Manager 2007 管理包

另请参阅

概念

Configuration Manager 2007 管理包的已知问题
Configuration Manager 2007 管理包监视方案

其他资源

Configuration Manager 2007 管理包概述


开始使用 Configuration Manager 2007 管理包

导入管理包之前的准备工作

部署 Microsoft® Configuration Manager 2007 管理包之前，需要查看 Operations Manager 2007 网页（网址是 http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）上的 Microsoft Operations Manager 2007 部署指南。本节介绍部署 Operations Manager 管理包的附加说明。

要部署 Configuration Manager 2007 管理包，必须完成下列过程：

  • 根据操作和组织需求设计监视环境。考虑性能和规模因素。建议您监视所有的主站点服务器以及默认管理点。
  • 将 Operations Manager 2007 代理部署到要监视的所有 Configuration Manager 2007 服务器组件计算机。最好采用循序渐进的方法。
  • 验证所有代理是否都能正常运行。
  • 配置用于 Configuration Manager 2007 提供程序和 Configuration Manager 2007 主站点服务器的 Operations Manager 2007 代理，以便它们可以作为其他计算机的代理。
  • 将 Configuration Manager 2007 管理包导入到 Operations Manager 2007 配置组。
  • 完成建议进行的测试和试验任务。
  • 完成建议进行的优化任务。

如何导入 Configuration Manager 2007 管理包

在使用管理包监视 Configuration Manager 2007 安装之前，必须将该管理包导入到 Operations Manager 2007。有关执行该操作的说明，请参阅 Operations Manager 网页（网址是 http://go.microsoft.com/fwlink/?LinkID=98348，该链接可能指向英文页面）上有关如何将管理包导入 Operations Manager 2007 的内容。

为自定义项创建新的管理包

大部分管理包都是密封的，因此，不能更改管理包文件中的任何原始设置。但是，可以创建自定义项（例如替代或新监视对象），并将其保存到其他管理包。默认情况下，Operations Manager 会将所有自定义项保存到默认管理包。作为最佳实践，您应为想要自定义的每个密封管理包单独创建一个管理包。

创建新的管理包以用于存储替代具有以下优点：

  • 可以简化将测试和预生产环境中创建的自定义项导出到生产环境的过程。例如，无需从多个管理包中导出包含自定义项的默认管理包，只需导出包含单个管理包的自定义项的管理包。
  • 这使您可以删除原始管理包而不必先删除默认管理包。包含自定义项的管理包依赖于原始管理包。这种依赖性要求您先删除包含自定义项的管理包，然后才能删除原始管理包。如果将所有自定义项都保存到默认管理包，则必须先删除默认管理包，然后才能删除原始管理包。
  • 可以简化跟踪自定义项并将其更新到各管理包的过程。

有关密封管理包和未密封的管理包的详细信息，请参阅“管理包格式”。有关管理包自定义项和默认管理包的详细信息，请参阅“关于管理包”。

为自定义项创建新的管理包

  1. 打开操作控制台，然后单击“管理”按钮。

  2. 右键单击“管理包”，然后单击“创建新的管理包”。

  3. 输入名称（例如“ConfigMgr 2007 MP 自定义项”），然后单击“下一步”。

  4. 单击“创建”。

另请参阅

概念

部署 Operations Manager 2007 代理
测试和试验 Configuration Manager 2007 管理包
自定义 Configuration Manager 2007 管理包


部署 Operations Manager 2007 代理

Operations Manager 代理运行在 Operations Manager 所监视的每台计算机上。要查看 Configuration Manager 2007 管理包监视的计算机组，请参阅本指南中的 Configuration Manager 2007 管理包的计算机组这一节。Operations Manager 2007 代理将收集托管计算机上的监视数据，将规则应用于收集到的数据，并将结果数据发送到 Data Consolidator Agent Manager (DCAM)。代理计算机上的监视功能由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理操作帐户提供。

要部署 Operations Manager 2007 代理，可以使用 Operations Manager 2007 安装向导或配置管理器软件分发。有关部署 Operations Manager 2007 代理和使用 Operations Manager 2007 安装向导的详细信息，请参阅 Microsoft Operations Manager 2007 部署指南中有关发现计算机和部署 Operations Manager 代理的章节。有关详细信息，请参阅 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。

注意
建议您使用 LocalSystem 帐户或具有配置管理器 WMI 命名空间 root、root\cimv2、root\sms 以及 SMS 注册表项和子项的足够访问权限的帐户，在配置管理器提供程序计算机上运行 Operations Manager 2007 代理。

要确定您的环境中是否可使用无代理监视，请参阅 Configuration Manager 2007 管理包监视方案中的“无代理监视支持”。

定义 SMS 环境变量以支持基于日志的规则

配置管理器管理包中的许多规则会读取基于配置管理器的日志文件以检查是否有错误。

“ConfigMgr 站点服务器 - 公用”下的以下规则分别基于 sender.log、distmgr.log 和 policypv.log 文件：

  • ConfigMgr 2007 组件:发送程序无法通过 LAN (标准安全)连接到远程站点
  • ConfigMgr 2007 组件:发送程序无法通过 RAS 连接到远程站点
  • ConfigMgr 2007 组件:发送程序无法通过 LAN (高级安全)连接到远程站点
  • ConfigMgr 2007 组件:分发管理器无法处理数据包
  • ConfigMgr 2007 组件:分发管理器无法插入 SMS 数据包，因为 CI_Contents 表中没有 SDM 类型内容。
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的软件更新策略
  • ConfigMgr 2007 组件:策略提供程序无法创建新的软件更新策略
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的相容性策略
  • ConfigMgr 2007 组件:策略提供程序无法创建新的相容性策略
  • ConfigMgr 2007 组件:策略提供程序无法向层次结构管理器通知策略更改

为了监视这些日志，必须指定配置管理器安装文件夹的位置。为此，请在站点服务器上创建 %SMS_INSTALL_DIR_PATH% 系统环境变量，以便运行在本地系统帐户或本地管理员用户环境之下的 MOM 代理有权访问 %SMS_INSTALL_DIR_PATH%\Logs 目录中的日志文件。有关设置系统环境变量的详细信息，请参阅系统环境变量的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=92316，该链接可能指向英文页面）。

要使 Operations Manager 运行状况代理能够使用此系统环境变量，可能需要重新启动配置管理器站点服务器。

将代理计算机配置为在低权限方案下运行

代理计算机上的监视功能由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理操作帐户提供。在 Microsoft Windows® 2000 中，操作帐户必须是本地管理员组的成员。在 Microsoft Windows™ 2003 中，在某些情况下可以使用低权限帐户作为代理的代理操作帐户。但是，要配置操作帐户以及 Operations Manager 2007 Service 和 Operations Manager 2007 Host 进程运行的用户上下文，使其拥有足够的权限来运行 Configuration Manager 2007 管理包功能，需要在代理计算机上执行大量手动配置操作。在 Microsoft Windows Server™ 2003 中，代理操作帐户必须至少具有下列用户权限：

  • 本地用户组的成员
  • 访问 Windows 事件日志
  • 管理审核和安全日志权限 (SeSecurityPrivilege)
  • 生成安全审核权限 (SeAuditPrivilege)
  • 允许本地登录权限 (SeInteractiveLogonRight)

在低权限方案中，Configuration Manager 2007 管理包要求用作代理操作帐户的帐户具有一些其他权限。下表详细介绍了必须手动配置的访问权限。

Configuration Manager 2007 管理包所需的访问权限类型

资源 | 权限类型 | 说明
Windows 事件日志 | 读 | 必须通过本地或全局策略为操作帐户授予“管理审核和安全日志”权限。
SMS 注册表项 | 读 | HKLM\Software\Microsoft\SMS 将操作帐户添加到注册表属性中，并提供所有子项继承的读权限。
Win32 服务注册表项 | 读 | HKLM\System\CurrentControlSet\Services 将操作帐户添加到本地用户组中。
脚本生成的临时文件 | 读和写 | TMP 变量指定的操作代理路径。对于本地系统帐户，该路径为 %Windir%\Temp 将操作帐户添加到本地用户组中。
SMS 日志文件 | 读 | <ConfigMgr 安装文件夹>\Logs 将操作帐户添加到文件夹属性中。
WMI 命名空间 | 读 | root 和 root\cimv2 不需要执行任何操作。
SMS WMI 命名空间 | 读 | 不需要执行任何操作。
SMS WMI 类 | 读 | SMS_Site SMS_R_System SMS_SiteControlFile SMS_ProviderLocation SMS_SCI_SiteDefinition SMS_SystemResourceList SMS_SystemResourceList SMS_SiteSystemSummarizer 将操作帐户添加到所有实例的类中。
默认实例的安全登录权限 | 授予访问权限 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“授予访问权限”权限，以进行安全登录。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Security\Logins。
默认实例上的主数据库的访问权限（必须有此访问权限才能识别 SMS 站点数据库） | 许可 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“许可”权限，以便访问主数据库。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Databases\Master\Users。 保留与该新用户相关的所有默认权限。
默认实例上的 SMS 站点数据库的访问权限 | 许可 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“许可”权限，以便访问 SMS 站点数据库。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Databases\<SMS site>\Users。 保留与该新用户相关的所有默认权限。

另请参阅

概念

自定义 Configuration Manager 2007 管理包
开始使用 Configuration Manager 2007 管理包
Configuration Manager 2007 管理包的已知问题
测试和试验 Configuration Manager 2007 管理包

其他资源

Configuration Manager 2007 管理包疑难解答


测试和试验 Configuration Manager 2007 管理包

除了 Microsoft Operations Manager 2007 部署指南中所述的管理包测试常规建议之外，本节列出适用于 Configuration Manager 2007 管理包的测试任务。有关测试管理包的详细信息，请访问 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。

测试任务

  • 验证 Configuration Manager 2007 计算机组是否由运行 Configuration Manager 2007 的计算机组成。
  • 在启用相关规则后，确保 Operations Manager 2007 中的视图和报告能正常运行。其中包括与 Configuration Manager 2007 处理速率和 Configuration Manager 2007 积压相关的视图。
  • 默认情况下，与 IIS 和 SQL Server 管理包等其他管理包相关的一些规则在 Configuration Manager 2007 管理包中是禁用的。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。
  • 默认情况下，将禁用所有性能测量规则，以最大限度降低对代理的 CPU、内存和网络资源的影响。可以启用这些规则，以进行更深入的监视。
  • 某些 Configuration Manager 2007 脚本（运行在 Configuration Manager 2007 提供程序计算机或 Configuration Manager 2007 站点服务器上的脚本，或用于访问 Configuration Manager 2007 站点数据库的脚本）不能在无代理模式下运行。验证是否将 Configuration Manager 2007 提供程序和 Configuration Manager 2007 站点数据库服务器这两个计算机组中的所有计算机都配置为代理托管计算机。此外，由于其中一些脚本可能要执行代理事件，因此需要验证这些代理是否已配置为启用代理。
  • 为了支持 SQL 群集，针对 ConfigMgr 站点数据库运行的所有脚本均应从站点服务器运行。确认这些脚本没有引发任何错误事件和警报。

另请参阅

概念

自定义 Configuration Manager 2007 管理包
部署 Operations Manager 2007 代理
Configuration Manager 2007 管理包的已知问题

其他资源

Configuration Manager 2007 管理包疑难解答


测试和试验 Configuration Manager 2007 管理包

除了 Microsoft Operations Manager 2007 部署指南中所述的管理包测试一般建议之外，本节还列出适用于 Configuration Manager 2007 管理包的试验任务。有关测试管理包的详细信息，请访问 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。

试验任务

  • 验证 Configuration Manager 2007 管理包是否已部署成功或从上一版本成功升级。
  • 使用控制台中的“创作”模式来验证和编辑适合于环境的自定义性能阈值。选择作用域或搜索适用的规则。
  • 分阶段启用性能规则，以评估这些规则对 Operations Manager 2007 性能的影响。
  • 验证 Configuration Manager 2007 计算机组是否由运行 Configuration Manager 2007 的计算机组成。
  • 在启用相关规则后，确保 Operations Manager 2007 中的视图和报告能正常运行。其中包括与 Configuration Manager 2007 处理速率、处理总计和 Configuration Manager 2007 积压相关的视图。
  • 默认情况下，将禁用与其他管理包相关的规则。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。
  • 默认情况下，将禁用某些性能规则，以最大限度降低对代理的 CPU、内存和网络资源的影响。可以启用这些规则，以对代理进行更深入的监视。
  • 确认没有生成 Configuration Manager 2007 脚本错误事件和警报。这些事件通常表示脚本的访问权限出现问题。
  • 验证 Operations Manager 和 SQL Server 的容量是否足以应付生产负载。
  • 验证是否符合操作流程和人员要求。
  • 验证通知是否正常发挥作用。
  • 验证 Operations Manager 2007 所使用的权限是否足以保证正常运行，而不至于太多。
  • 操作帐户代理只能由 LocalSystem 帐户来运行。如果操作帐户代理没有以 LocalSystem 权限运行，则应确保满足最低的安全权限。有关详细信息，请参阅本指南的部署 Operations Manager 2007 代理小节中的“将代理计算机配置为在低权限方案下运行”。
  • 验证 Configuration Manager 2007 服务器和 Configuration Manager 2007 客户端角色是否显示在“计算机状态”视图中。单击承载上述每个角色的计算机，然后检查属性是否显示在细节窗格中。
  • 在“计算机状态”视图中，单击 ConfigMgr 服务器和 ConfigMgr 客户端实例，然后检查其角色是否显示在细节窗格中。
  • 在“计算机状态”视图中，双击 ConfigMgr 服务器和 ConfigMgr 客户端实例，然后检查其属性是否显示在状态视图细节窗格中。
  • 验证站点和站点层次结构状态视图是否正常发挥作用。
  • 通过单击任务来验证 Configuration Manager 2007 管理员控制台任务是否正常执行。如果该任务无法执行，请检查是否已安装 Configuration Manager 2007 管理员控制台以及登录的用户是否有足够的权限来执行控制台任务。
  • 验证站点层次结构图。对于 Operations Manager 2007 代理安装在其 Configuration Manager 2007 提供程序本地的站点，验证是否所有站点系统都能显示出来。如果未显示某个站点系统，请检查 Configuration Manager 2007 管理员控制台，以查看该站点系统是否已被该站点发现，并显示在“所有系统”集合中。此外，还要验证是否已为每台服务器输入 FQDN。

完成初步测试和优化之后，导出默认管理包或已创建的自定义 Configuration Manager 2007 管理包，以备份所做的更改。

另请参阅

概念

自定义 Configuration Manager 2007 管理包
部署 Operations Manager 2007 代理
Configuration Manager 2007 管理包的已知问题

其他资源

Configuration Manager 2007 管理包疑难解答


自定义 Configuration Manager 2007 管理包

为了实现最佳监视效果，可以根据贵公司的业务需要自定义 Configuration Manager 2007 管理包。如果现有规则不能满足贵公司的要求，可以对其进行修改或创建新的规则。

注意 应始终在进行更改之前备份 Configuration Manager 2007 管理包。通过 Operations Manager 2007 管理包导出向导，可以备份默认管理包或未密封的自定义管理包。

自定义操作可包括下列任一操作：

  • 使用替代来启用和禁用规则。
  • 创建新规则和监视器。
  • 修改警报条件、警报严重性和警报抑制。
  • 设置监视器的自定义阈值。所有性能阈值监视器都是可配置的。如果默认阈值不是最佳设置，则可能收到不必要的警报，或可能因阈值设置过高，不适用于您的环境，从而导致收不到警报。
  • 对规则和监视器使用替代来配置收件箱监视阈值和轮询间隔。
  • 添加基于脚本的新收件箱自定义监视事件规则。要添加新的收件箱监视规则，可在默认管理包或自定义管理包中创建新规则，然后为脚本输入参数（FileCountThreshold 和 InboxDirectoryName）和计划创建替代。
  • 通过替代来设置性能测量的轮询间隔。
  • 将内容添加到公司知识中。
  • 通过更改对规则或监视器的响应或添加对规则或监视器的新响应来自定义警报响应。
  • 对代理启用性能测量规则将会生成大量数据，可能会导致性能问题。默认情况下，将禁用性能测量规则，以便您确定是否可以接受可能造成的性能影响。可检查性能规则，并小批量启用这些规则，这样就可以评估这些规则对 Operations Manager 2007 性能（包括数据库的大小）的影响。
  • 检查规则是否适用于您的环境。默认情况下，将禁用与其他管理包相关的规则。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。

有关管理包自定义以及如何导出管理包自定义的详细信息，请参阅 Operations Manager 2007 相关网页（网址是 http://go.microsoft.com/fwlink/?LinkId=100980，该链接可能指向英文页面）中有关 Operations Manager 2007 管理包的主题以及有关如何导出管理包自定义的主题。

收件箱监视

通过 Operations Manager 2007 导出向导，可以在进行其他更改之前保存默认管理包或任何自定义管理包中的更改。

配置收件箱监视规则

要将这些规则部署到中央站点服务器、主站点服务器和辅助站点服务器，必须根据“Microsoft ConfigMgr 2007 站点服务器 - 公用”中的规则在管理包中创建新规则。此后，可以对相应的站点服务器类应用这些规则，修改阈值，并启用该规则。

  • ConfigMgr 收件箱:监视收件箱
  • ConfigMgr 收件箱:监视收件箱脚本错误
  • ConfigMgr 收件箱:超过阈值

“ConfigMgr 收件箱:超过阈值”事件处理规则将监视“ConfigMgr: 监视收件箱脚本错误”脚本。对于超过指定的阈值计数的每个收件箱，都会生成一个唯一的警报。

该脚本的默认阈值设置是每个收件箱中最多容纳 10,000 个文件。可以在默认管理包或自定义管理包中为此参数或任何脚本参数创建该值的替代值。如果超过了该值，将引发“超过阈值”事件。可以通过计算服务器上每个正常运行的进程的每日预期负载，然后增加可接受的缓冲百分比来修改该阈值设置。默认情况下，收件箱监视规则每天运行一次，在 01:00 开始，各个规则依次错开 15 分钟运行。为了最大限度降低性能影响，建议您保留此间隔，或对其进行调整，以尽可能减少收件箱监视规则之间的任何运行脚本时间重叠。

下表中列出了收件箱监视规则、默认阈值和 SMS Executive 提供程序所监视的收件箱。

SMS Executive 收件箱监视

收件箱监视规则名称 | 默认阈值 | 收件箱名称
ConfigMgr 收件箱:监视收件箱脚本错误 | n/a | n/a
ConfigMgr 收件箱:超过阈值 | n/a | n/a
ConfigMgr 收件箱:监视 <收件箱目录名> | 10000 | Inboxes\auth\dataldr.box

替代收件箱监视事件规则的步骤

在替代收件箱监视事件规则前，Operations Manager 2007 站点服务器必须发现类型为“Microsoft Configuration Manager 2007 站点服务器”的 Configuration Manager 2007 站点服务器对象。

替代收件箱监视事件规则

  1. 在“System Center Operations Manager 2007”控制台中，单击“创作”。

  2. 导航到“创作”>“管理包对象”>“规则”。

  3. 如果“查找”文本框不可用，请导航到“视图”，然后单击“查找”。

  4. 单击“更改作用域”，然后单击 Microsoft ConfigMgr 2007 站点服务器的作用域。

  5. 右键单击要修改的相应 ConfigMgr 收件箱监视事件规则，并选择“替代规则”，然后单击“对于类型为 Microsoft ConfigMgr 2007 站点服务器的所有对象”。

  6. 在“替代属性”中，选中“已启用”替代复选框，然后将“替代设置”设为“真”以启用规则，或将“替代设置”设为“假”以禁用规则。

  7. 在“替代属性”中，选中该替代复选框，并将“替代设置”设为所需的值。单击“确定”。修改后的阈值将分发到服务器。

定义 SMS 管理用户界面变量以支持控制台任务

如果 Configuration Manager 2007 站点服务器或管理用户界面是通过安装已导入 Configuration Manager 2007 管理的 Operations Manager 2007 配置的，则配置管理器控制台可从任务窗格启动下列 Configuration Manager 2007 用户界面组件：

  • 资源管理器
  • 配置管理器控制台
  • 服务管理器
  • 状态消息

为了启动这些应用程序，需要创建 SMS_ADMIN_UI_PATH 系统环境变量。默认情况下，此环境变量指向包含配置管理器控制台的目录 [ConfigMgr 安装路径]\AdminUI\bin\i386。

启用 Configuration Manager 2007 规则

默认情况下，将禁用某些管理包规则，包括监视“LAN 唤醒”功能的性能测量计数器和规则。要使用这些规则，必须启用它们。

  • 在 Configuration Manager 2007 管理包中，默认情况下处于禁用状态的“LAN 唤醒”规则包括：
  • ConfigMgr 2007 性能阈值:站点服务器收件箱 WOLCMGR.box 积压 > 20 (1 小时内)
  • ConfigMgr 2007 性能阈值:站点服务器收件箱 WOLCMGR.box\data 积压 > 100 (1 小时内)
  • ConfigMgr 2007 性能阈值:SMS LAN 唤醒通信管理器失败的数据包总数 > 100 (15 分钟内)
  • ConfigMgr 2007 性能阈值:挂起的 SMS LAN 唤醒通信管理器请求总数 > 10,000 (3 小时内)
  • ConfigMgr 2007 缺失状态:修补程序管理同步组件已成功下载该目录，并使用新目录版本更新了分发点。
注意
只有 Operations Manager 2007 SP1 及更高版本才支持“ConfigMgr 2007 缺失状态:修补程序管理同步组件已成功下载该目录，并使用新目录版本更新了分发点”规则。

要启用已禁用的管理包规则，请执行下列步骤。

步骤

启用已禁用的管理包规则

  1. 在操作控制台中，单击“创作”。

  2. 在“导航”窗格中，导航到“创作”>“管理包对象”，然后单击“规则”。

  3. 在“规则”窗格中，搜索要启用的规则。如果规则列表上面的“查找”栏不可用，请导航到“视图”，然后单击“查找”。

  4. 右键单击要启用的规则的名称，并导航到“替代”>“替代规则”，然后单击该规则所监视的一组对象。

  5. 将“已启用”设置为“真”，然后根据环境的需要来修改任意阈值。单击“确定”。

另请参阅

概念

开始使用 Configuration Manager 2007 管理包
Configuration Manager 2007 管理包监视方案
支持的 Configuration Manager 2007 管理包配置
测试和试验 Configuration Manager 2007 管理包

其他资源

Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 与 Operations Manager 2007 的集成

Configuration Manager 2007 通过用于启动配置管理器管理员控制台组件的 Operations Manager 控制台任务与 Operations Manager 控制台相集成。

它还支持在软件分发和软件更新程序执行期间在运行 Operations Manager 2007 代理的配置管理器客户端上启用维护模式。维护模式在站点备份期间也是启用的，但不可对其进行配置。

Operations Manager 2007 控制台任务

Configuration Manager 2007 管理员控制台任务要求将 Configuration Manager 2007 管理员控制台安装在 Operations Manager 2007 操作控制台所在的同一台计算机上。系统环境变量 SMS_ADMIN_UI_PATH 需要定义为包含 Configuration Manager 2007 控制台程序的文件夹的路径。有关设置系统环境变量的详细信息，请参阅系统环境变量的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=92316，该链接可能指向英文页面）。

可从 Operations Manager 控制台启动下列 Configuration Manager 2007 任务。

任务 | 描述
ConfigMgr 2007 管理员控制台 | 打开指向当前所选计算机上的 Configuration Manager 2007 管理员控制台。此任务适用于承载 Configuration Manager 2007 站点服务器角色的计算机。
所有 ConfigMgr 2007 状态消息 | 系统将提示计算机的站点服务器，打开 MMC 窗口，执行状态消息查询，以返回与当前所选计算机相关的所有状态消息。此任务适用于所有系统。
ConfigMgr 2007 服务管理器 | 打开指向当前所选计算机的 Configuration Manager 2007 服务管理器。此任务适用于承载 Configuration Manager 2007 站点服务器角色的计算机。
ConfigMgr 2007 资源管理器 | 系统将提示计算机的站点服务器，并打开 MMC 窗口，其中的 Configuration Manager 2007 资源管理器显示了当前所选计算机的相关数据。此任务适用于所有系统。

Configuration Manager 2007 的维护模式

System Center Configuration Manager 2007 支持在使用其软件分发和软件更新功能时对 Operations Manager 2007 使用维护模式。通过将 MOM 代理置于维护模式，可在运行配置管理器客户端的计算机上抑制警报。

在 Configuration Manager 2007 将软件分发到计算机时，通常需要临时禁用由目标计算机生成的基于 Operations Manager 规则的警报。例如，在将修补程序和安全修补程序部署到服务器时，可能需要关闭某些线程和服务。如果管理包监视这些服务器上的线程或服务，则可能生成大量 Operations Manager 警报，从而造成 Operations Manager 服务器负载过多。

如果选中“此程序运行时禁用 MOM 警报”复选框，将抑制 Operations Manager 警报，直至软件分发完成为止。Configuration Manager 2007 管理员可在配置管理器数据包程序属性中设置此复选框。设置此选项可以在客户端计算机执行该程序时，抑制以客户端计算机为目标的所有管理包的 Operations Manager 警报。允许的最长运行时间将用作维护模式持续时间的超时。

为配置管理器软件更新启用维护模式

软件更新在客户端计算机上运行时，由 Configuration Manager 2007 分发的软件更新可能会生成警报。要避免收到此计划维护的警报，可以在软件更新持续时间内禁用警报。

要在软件更新运行时禁用 Operations Manager 警报，请执行以下步骤。

步骤

在软件更新运行时禁用 Operations Manager 警报

  1. 在 Configuration Manager 2007 控制台中，导航到“系统中心配置管理”/“站点数据库 - <站点服务器名称>”/“计算机管理”/“软件更新”/“部署管理”。

  2. 右键单击更新名称，然后单击“属性”。

  3. 在“程序属性”对话框中，单击“事件生成”选项卡。

  4. 选中“软件更新运行时禁用 Operations Manager 警报”，然后单击“确定”。

在为配置管理器软件更新启用维护模式后，在分发和运行配置管理器更新时，客户端计算机将进入维护模式。

为配置管理器软件分发启用维护模式

用于分发软件的软件分发程序在客户端计算机上运行时，由 Configuration Manager 2007 分发的软件可能会生成警报。要避免收到此计划维护的警报，可以在软件分发程序持续时间内禁用警报。

要在此软件分发程序运行时禁用 Operations Manager 警报，请执行以下步骤。

步骤

在软件分发程序运行时禁用 Operations Manager 警报

  1. 在 Configuration Manager 2007 控制台中，导航到“系统中心配置管理”/“站点数据库 - <站点服务器名称>”/“计算机管理”/“软件分发”/“数据包”/“<数据包名称>”/“程序”。

  2. 在细节窗格中，右键单击程序名称，然后单击“属性”。

  3. 在“程序属性”对话框中，单击“MOM 维护模式”选项卡。

  4. 选中“此程序运行时禁用 Operations Manager 警报”，然后单击“确定”。

在为配置管理器程序启用维护模式后，在分发和运行配置管理器数据包时，客户端计算机将进入维护模式。

注意
在“程序属性”对话框的“要求”选项卡中，可通过选择“最长允许运行时间”属性来设置维护模式的超时时间。

针对 Configuration Manager 2007 程序故障生成警报

如果由 Configuration Manager 2007 分发的软件无法安装在客户端计算机上，则可能需要向管理员发出警报。

要在软件分发程序失败时生成 Operations Manager 警报，请执行以下步骤。

步骤

在软件分发程序失败时生成 Operations Manager 警报

  1. 在 Configuration Manager 2007 控制台中，导航到“系统中心配置管理”/“站点数据库 - <站点服务器名称>”/“计算机管理”/“软件分发”/“数据包”/“<数据包名称>”/“程序”。

  2. 在细节窗格中，右键单击程序名称，然后单击“属性”。

  3. 在“程序属性”对话框中，单击“MOM 维护模式”选项卡。

  4. 选中“Generate Operations Manager alert if this program fails”，然后单击“确定”。

启用此属性之后，如果软件程序无法运行，则该程序将发送 Operations Manager 警报。

针对 Configuration Manager 2007 程序故障生成警报

如果由 Configuration Manager 2007 分发的软件无法安装在客户端计算机上，则可能需要向管理员发出警报。

要在软件分发程序失败时生成 Operations Manager 警报，请执行以下步骤。

步骤

在软件更新安装失败时生成 Operations Manager 警报

  1. 在 Configuration Manager 2007 控制台中，导航到“系统中心配置管理”/“站点数据库 - <站点服务器名称>”/“计算机管理”/“软件更新”/“部署”。

  2. 在细节窗格中，右键单击更新名称，然后单击“属性”。

  3. 在“程序属性”对话框中，单击“MOM 维护模式”选项卡。

  4. 选中“软件更新安装失败时生成 Operations Manager 警报”，然后单击“确定”。

启用此属性之后，在软件更新安装失败时将发送 Operations Manager 警报。

另请参阅

概念

Configuration Manager 2007 管理包的每日任务
Configuration Manager 2007 管理包的每周任务
Configuration Manager 2007 管理包的每月任务

其他资源

执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 管理包监视方案

Microsoft® System Center Configuration Manager 2007 管理包为 Configuration Manager 2007 监视提供了新功能和经过改进的功能。以下几节介绍 Configuration Manager 2007 管理包支持的主要方案，以及各个方案的功能。

服务可用性

服务发现

可用性监视

计算机状态监视

站点层次结构状态监视

站点状态监视

无代理监视支持

性能阈值监视

性能监视

配置管理器关键状态消息监视

站点系统状态监视

Executive 故障转储监视

积压监视

常规运行状况监视

配置管理器软件更新管理监视

配置管理器站点备份监视

所有警报的产品知识内容

所有配置管理器服务器和客户端角色的计算机组

扩展监视

软件分发程序运行状态

配置管理器任务监视

组件日志文件监视

Configuration Manager 2007 收件箱监视

服务可用性

服务可用性方案同时利用 System Center Operations Manager 2007 的服务可用性功能和 NT 事件系统日志中的服务控制管理器事件，以此来监视配置管理器服务可用性。服务可用性监视功能将在满足以下条件时生成警报：

  • 当配置管理器站点系统上基于配置管理器的服务停止时。
  • 当配置管理器站点系统上配置管理器的关键从属服务（例如 Windows 管理规范 (WMI)）停止或无法启动时。
  • 当配置管理器站点系统上配置管理器的其他从属服务（例如 Microsoft SQL Server™、Internet Information Services (IIS) 和后台智能传输服务 (BITS)）停止或无法启动时。
  • 当配置管理器站点备份服务启动或停止时生成警报；这样，您就可以监视备份持续时间，并将其他配置管理器服务的停止事件与配置管理器站点备份相关联。

服务发现

服务发现是指发现托管计算机上的数据、服务器角色和组件的过程。服务发现会返回与配置管理器服务器和配置管理器客户端相关的信息。它还支持在状态监视视图中显示配置管理器服务器和配置管理器客户端角色。

将管理包部署到代理之后，将收集特定于服务器的服务发现数据，并开始在系统中心操作控制台中显示这些数据。在第一次收集服务发现数据之前，需要为特定任务标识角色、计算机组和目标计算机的功能将不可用。

配置管理器管理包使用以下事件处理规则：

  • ConfigMgr 2007 服务发现

用于启动相应的服务发现脚本：

  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Service Discovery - Client
  • 默认情况下，这些脚本将使用异步定时提供程序每 24 小时收集一次服务发现数据。

可用性监视报告

Configuration Manager 2007 管理包涵盖下列可用性报告，这些报告用于监视以下服务器角色的检测信号：

  • 服务器可用性
  • 分发点可用性
  • 管理点可用性
  • PXE 服务点可用性
  • 站点服务器可用性
  • 软件更新点可用性
  • 系统健康验证程序可用性
  • 状态迁移点可用性
  • 站点数据库服务器可用性

所有报告都是针对 Operations Manager 数据库运行的，这使您可以指定报告的持续时间。

有关服务器可用性报告的详细信息，请参阅 Configuration Manager 2007 管理包的报告。

服务器角色可用性监视

系统将监视以下角色的可用性：

  • 管理点
  • NLB 管理点
  • 设备管理点
  • 系统健康验证程序
  • 状态迁移点
  • PXE 服务点
  • 软件更新点
  • 分发点
  • 站点数据库服务器

组件可用性监视

系统将监视以下组件的可用性，这些组件可定期生成报告其可用性状态的检测信号：

  • INBOX MANAGER
  • INBOX MONITOR
  • SITE COMPONENT MANAGER
  • MP CONTROL MANAGER
  • MP FILE DISPATCH MANAGER
  • OUTBOX MONITOR
  • WAKEONLAN COMMUNICATION MANAGER
  • WAKEONLAN MANAGER
  • WSUS CONFIGURATION MANAGER
  • WSUS SYNC MANAGER
  • WSUS CONTROL MANAGER
  • DATABASE NOTIFICATION MONITOR
  • OFFER STATUS SUMMARIZER
  • COMPONENT STATUS SUMMARIZER
  • SITE SYSTEM STATUS SUMMARIZER
  • COMPONENT MONITOR
  • STATE MIGRATION POINT
  • PXE SERVICE POINT

计算机状态监视

计算机状态监视功能以表格形式显示所有配置管理器服务器和客户端的运行状况。服务器角色和组件是通过服务发现来管理的。而组件的健康状况是通过一组规则和监视器来管理的。

下表按颜色显示了所监视的配置管理器组件的健康状况。

配置管理器服务器状态监视

ConfigMgr 服务器组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
站点服务器 (SS) | 是 | 是 | 是
管理点 (MP) | 是 | 是 | 是
站点数据库 (DB) | 是 | 是 | 是
分发点 (DP) | 是 |  | 是
服务器定位器点 (SLP) | 是 |  | 是
报告点 (RP) | 是 |  | 是
状态迁移点 (SMP) | 是 | 是 | 是
PXE 服务点 (PSP) | 是 | 是 | 是
回退状态点 (FSP) | 是 | 是 | 是
系统健康验证程序 (SHV) | 是 | 是 | 是
软件更新点 (SUP) | 是 | 是 | 是
提供程序 |  |  |
性能 | 是 | 是 | 是

配置管理器客户端状态监视

ConfigMgr 客户端组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
客户端服务 | 是 |  | 是

站点层次结构状态监视

站点层次结构状态监视功能以表格的形式显示站点层次结构中所有 Configuration Manager 2007 托管系统的运行状况。系统的健康状况是通过一组规则和监视器来管理的。

下表按颜色显示了所监视的配置管理器系统的健康状况。

配置管理器站点层次结构状态监视

ConfigMgr 服务器组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
可用性 | 是 | 是 | 是
性能 | 是 | 是 | 是

站点状态监视

站点状态监视功能以表格的形式显示所有配置管理器托管服务器的运行状况。站点的健康状况是通过一组规则和监视器来管理的。

下表按颜色显示了所监视的配置管理器站点的健康状况。

配置管理器站点状态监视

ConfigMgr 服务器组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
可用性 | 是 | 是 | 是
性能 | 是 | 是 | 是

无代理监视支持

配置管理器管理包支持监视无代理托管计算机，但下列功能除外：

  • 配置管理器关键状态消息监视
  • 站点系统状态监视

以下脚本支持上述功能：

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks

这些脚本必须在本地运行才能访问配置管理器资源。如果这些脚本无法访问资源，则会引发脚本错误事件和警报。

性能阈值监视

如果性能级别下降，可能会造成延迟，并在时间、性能和数据准确性方面影响客户服务级别协议 (SLA)。检测和解决配置管理器基础结构中的关键性能问题非常重要。当所监视的条件超过特定级别时，性能阈值监视功能会生成警报：

  • 配置管理器站点系统上与 CPU、分页文件和内存相关的计算机级常规运行状况度量。
  • 在配置管理器站点服务器收件箱中，配置管理器文件（例如计划程序作业、发送请求、软件计数记录、发现数据记录 (DDR) 以及软件清单和硬件清单记录）的总数。
  • 在配置管理器管理点消息队列中，与状态消息、DDR、软件清单和硬件清单相关的配置管理器消息总数。
  • SHV 响应和条件。
  • SMS 发件箱中的文件。
  • PSP 请求。
  • SMP 客户端总数及磁盘空间总量。
  • WOL 数据包。

性能监视

通过性能监视功能，可以监视积压、处理速率和配置管理器关键对象总数的趋势，以便查明问题并主动加以解决。通过使用 Operations Manager 2007 视图和报告，性能趋势功能以图形方式监视下列趋势：

  • 在配置管理器站点服务器的收件箱中，与计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单、WOL 数据包以及状态和状态消息相关的积压文件。
  • 配置管理器站点服务器上的计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单、WOL 数据包、SUP 更新以及状态和状态消息的处理速率。
  • 配置管理器站点服务器上的计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单、WOL 数据包、SUP 更新以及状态和状态消息的总数。
  • 与配置管理器管理点服务器消息队列中的 DDR、硬件清单、软件清单、软件计数、状态和状态消息以及其他配置管理器对象相关的消息积压。
  • 配置管理器管理点服务器消息队列中的 DDR、硬件清单、软件清单、软件计数、状态和状态消息、SDM 数据包请求以及其他配置管理器对象的处理速率。
  • 配置管理器管理点服务器消息队列中的 DDR、硬件清单、软件清单、中继、SDM 数据包请求和状态消息的总数。
  • 配置管理器站点系统上与 CPU、分页文件和内存相关的计算机级运行状况度量。
  • 当前运行的配置管理器 Executive 线程的总数。
  • ISAPI 扩展对 IIS 的请求的速率。
  • 站点系统上发件箱中的积压。
  • SMS 服务器可用性请求。
  • SHV 条件和 SoH 请求。
  • PSP 请求处理。
  • SMP 客户端状态处理和可用磁盘空间。
  • 配置管理器设备管理点服务器消息队列中的 DDR、硬件清单、软件清单、软件计数、状态消息和其他配置管理器对象的处理速率。

配置管理器关键状态消息监视

配置管理器基础结构会生成配置管理器状态消息。识别与服务器相关的配置管理器关键状态消息并及时解决问题非常重要。这些消息通常表明配置管理器基础结构的可用性、性能、安全性、配置和整体运行状况存在问题。

当检测到配置管理器的关键状态消息（例如组件安装、数据库连接和站点连接）时，配置管理器关键状态消息监视功能将生成警报。系统将每半小时准点扫描一次配置管理器站点数据库，以了解是否有配置管理器关键状态消息。

站点系统状态监视

配置管理器通过其站点系统状态摘要生成器定期监视站点系统的基本运行状况，该摘要生成器每一小时正点轮询一次配置管理器站点系统。要从此功能受益，必须迅速对此状态采取措施以防配置管理器性能降低。站点系统状态监视提供了监视功能，可在检测到对配置管理器站点系统的运行状况至关重要的配置管理器站点系统摘要生成器状态时生成警报。所监视的一些状态包括：配置管理器站点系统停机，SQL Server 的数据库空间或日志空间不足，以及配置管理器站点系统的 NTFS 驱动器上的物理磁盘空间不足。

Executive 故障转储监视

配置管理器 Executive 服务故障会影响配置管理器的可用性，因此，了解故障转储的发生时间并查明根本原因非常重要。当 SMS Executive 服务发生故障时，它将在 <ConfigMgr 安装路径>\Logs\CrashDumps 目录下创建一个故障转储日志子目录。创建此子目录的操作会受到监视，并且会针对依赖于 SMS Executive 服务的所有配置管理器服务器角色生成警报。

Configuration Manager 2007 Monitor SMS Executive Crash Dumps 脚本仅报告最新的故障转储。无论上次故障转储发生在多久以前（从脚本第一次运行到卸载 SMS Executive 并在稍后重新安装的任何时候），此规则都适用。

以下相关规则适用于“基于 SMS Executive 的 Microsoft Configuration Manager 2007 组件服务器”类：

  • ConfigMgr 2007 故障转储:监视 SMS Executive

“ConfigMgr 2007 故障转储:监视 SMS Executive”将“每 60 分钟”启动一次脚本，“在 00:10 同步”。此规则的“知识”属性页上提供了摘要信息。

  • ConfigMgr 2007 故障转储:监视 SMS Executive 脚本错误

“ConfigMgr 2007 故障转储:监视 SMS Executive 脚本错误”监视可能发生的任何脚本错误事件并发出警报。只有编号为 1102 的脚本错误事件才会报告所有脚本错误。此规则的“知识”属性页上提供了解决警报的相关信息。

  • ConfigMgr 2007 故障转储:SMS Executive 故障

“ConfigMgr 2007 故障转储:SMS Executive 故障”监视故障转储事件并在事件发生时发出警报。此规则的“知识”属性页上提供了解决警报的相关信息。

积压监视

积压会造成延迟，从而在时间、性能和数据准确性方面影响客户的 SLA。及时检测并解决配置管理器基础结构中的关键性能问题非常重要。当下列各项的积压在给定时段内超过阈值时，将生成警报：

  • 配置管理器站点服务器收件箱中配置管理器文件（例如计划程序作业、发送请求、软件计数记录、DDR、软件清单和硬件清单记录、WOL 请求以及状态和状态消息）的总数。
  • 配置管理器站点服务器队列中配置管理器对象（例如计划程序作业、发送请求、软件计数记录、DDR、软件清单和硬件清单记录、WOL 请求以及状态消息）的总数。
  • 配置管理器管理点消息队列中与状态消息、DDR、软件清单和硬件清单相关的配置管理器消息总数。
  • 站点系统发件箱中文件（例如软件计数记录、DDR、软件清单和硬件清单记录以及状态和状态消息）的总数。

常规运行状况监视

当配置管理器服务器上的运行状况度量在给定时段内超过特定阈值时，常规运行状况监视功能将生成警报。常规运行状况监视将检查下列度量：

  • 处理器时间达到 95%（3 小时内）
    • Smsexec
    • Ccmexec
    • Total
  • 分页文件使用率达到 98%（3 小时内）

配置管理器软件更新管理监视

配置管理器管理员依赖于配置管理器软件更新管理功能来保持企业中的客户端和服务器计算机与最新的安全更新保持同步。修补程序管理监视功能将检测配置管理器软件更新管理处理和配置过程中的任何故障。如果出现以下情况，则配置管理器软件更新管理监视功能将生成警报：

  • 无法配置 WSUS 服务器。
  • 配置管理器无法订阅 WSUS 服务器的更新。
  • 配置管理器软件更新管理同步过程失败。
  • 在配置管理器软件更新管理过程中，无法使用更新来更新配置管理器分发点。

配置管理器站点备份监视

了解配置管理器备份开始、完成或失败的时间可以帮助配置管理器管理员审核备份活动。可以计划定期运行配置管理器备份来备份配置管理器的数据、策略和配置。

监视此备份过程的失败并采取纠正措施非常重要。即使配置管理器备份成功，也会影响服务可用性，因为此过程会停止和启动 SMS 站点组件管理器和 SMS Executive。监视配置管理器备份有助于跟踪这些服务的已知停机时间，因为在备份过程中，将抑制与这些服务停止有关的警报。下列规则支持监视配置管理器站点备份：

  • ConfigMgr 2007 状态:站点备份成功完成
  • ConfigMgr 2007 状态:站点备份失败
  • ConfigMgr 2007 状态:在当前备份任务完成后，Site Backup 才能开始执行备份过程
  • ConfigMgr 2007 状态:Site Backup 发现 SQL 备份路径为空或无效
  • ConfigMgr 2007 服务已停止运行:SMS_SITE_BACKUP
  • ConfigMgr 2007 服务已开始运行:SMS_SITE_BACKUP
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 异常终止
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 在启动时挂起
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 无法启动
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 无法登录
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 依赖于另一服务，但该服务无法启动或不存在

  • ConfigMgr 2007 服务运行:SMS_SITE_VSS_WRITER
  • ConfigMgr 2007 服务故障:SMS_SITE_VSS_WRITER 异常终止
  • ConfigMgr 2007 服务故障:SMS_SITE_VSS_WRITER 在启动时挂起
  • ConfigMgr 2007 服务故障:SMS_SITE_VSS_WRITER 无法启动
  • ConfigMgr 2007 服务故障:SMS_SITE_VSS_WRITER 无法登录
  • ConfigMgr 2007 服务故障:SMS_SITE_VSS_WRITER 依赖于另一服务，但该服务无法启动或不存在

所有警报的产品知识内容

管理员可参考所有警报的产品知识内容，以帮助找出具体问题并解决问题。要访问产品知识内容，请右键单击任何规则名称，单击“属性”，然后单击“产品知识”选项卡。

所有配置管理器服务器和客户端角色的计算机组

计算机组映射到特定配置管理器服务器和客户端角色。规则应用和监视器应用基于同样映射到配置管理器服务器和客户端角色的类。这样，管理员可以拥有相应级别的控制，以便应用管理包规则。

扩展监视

配置管理器管理包中提供的规则涵盖基本服务、性能测量以及以下相关技术的性能阈值监视：SQL Server、IIS、BITS、Windows 操作系统、WMI、WSUS、Windows 部署服务和 Trivial FTP。默认情况下，上述部分支持是禁用的。您可以启用并使用配置管理器管理包中的这种有限支持，但是建议您同时导入并使用这些特定产品的管理包。

  • 使用 SQL Server 管理包可扩展对配置管理器站点数据库、带有复制站点数据库的管理点以及包含 SQL Server 从属对象的软件更新点的监视。
  • 使用 IIS 管理包可监视报告点、管理点、服务器定位器点、状态迁移点和回退状态点上的 IIS。IIS 管理包还可以监视启用了 BITS 的分发点。
  • 使用 Microsoft Windows 操作系统管理包可监视 Windows 基本组件，例如 CPU、磁盘和内存统计信息。

还有其他管理包可增强对配置管理器基础结构的监视，对于这些管理包，Configuration Manager 2007 管理包未提供规则。

  • 如果您出于可伸缩性的考虑要使用网络负载平衡来支持配置管理器层次结构中的多个管理点，可使用 Windows 网络负载平衡管理包。
  • 使用 Windows Active Directory® 管理包监视 Active Directory 基础结构的运行状况。

如果您在环境中部署了多个管理包，基于各管理包中存在的规则，您可能会收到冗余警报。如果您禁用冗余监视规则，则可能会影响所部署管理包的状态视图的准确性。在接收冗余警报和使所部署的每个管理包的状态监视正常运行之间，应仔细权衡取舍。根据您所部署的附加管理包，应检查这些冗余规则，以确定需要在您的环境中启用哪些规则。安装这些管理包后，请确认已对其进行了必要的自定义，并且配置正确，启用了适当的规则。

软件分发程序运行状态

配置管理器客户端可以通过管理包来报告程序的失败。

管理员可以在“程序属性”对话框的“MOM 维护模式”选项卡上选中“Generate Operations Manager alert if this program fails”复选框。

步骤

如果在 Configuration Manager 2007 程序无法运行时启用 Operations Manager 2007 警报，则需要执行以下步骤：

为配置管理器程序启用 Operations Manager 2007 警报

  1. 在配置管理器控制台中，导航到“Systems Center Configuration Manager”/“站点数据库 - <站点服务器名称>”/“计算机管理”/“软件分发”/“数据包”/“<数据包名称>”/“程序”。

  2. 在细节窗格中，右键单击“程序”，然后选择“属性”。

  3. 单击“MOM 维护模式”选项卡。

  4. 选中“Generate Operations Manager alert if this program fails to run”复选框。单击“确定”。

ConfigMgr 任务监视

系统会监视针对 ConfigMgr 站点数据库执行的所有任务（例如集合评估、状态消息汇总和站点维护），以了解完成状态和持续时间。如果任务失败或执行时间超过最长预期持续时间，将会引发警报。

组件日志文件监视

下列规则基于监视 sender.log、distmgr.log 和 policypv.log 文件：

  • SMSv4 组件:发送程序无法通过 LAN (标准安全)连接到远程站点。
  • SMSv4 组件:发送程序无法通过 RAS 连接到远程站点。
  • ConfigMgr 2007 组件:发送程序无法通过 LAN (高级安全)连接到远程站点。
  • ConfigMgr 2007 组件:分发管理器无法处理数据包。
  • ConfigMgr 2007 组件:分发管理器无法插入 SMS 数据包，因为 CI_Contents 表中没有 SDM 类型内容。
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的软件更新策略。
  • ConfigMgr 2007 组件:策略提供程序无法创建新的软件更新策略。
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的相容性策略。
  • ConfigMgr 2007 组件:策略提供程序无法创建新的相容性策略。
  • ConfigMgr 2007 组件:策略提供程序无法向层次结构管理器通知策略更改。

Configuration Manager 2007 收件箱监视

Configuration Manager 2007 的大多数关键服务器端活动都是通过读取和写入收件箱中的文件来完成的。如果 Configuration Manager 2007 收件箱过满，则表明 Configuration Manager 2007 的处理滞后。这可能有多种原因，包括但不限于文件损坏、进程停止、磁盘空间不足或软件分发活动异常多。这类问题很少出现，但对于拥有大量站点的客户而言，这些问题很严重。

作为 SMS Executive 服务的线程运行的收件箱监视器会监视由服务组件排入队列的项目数，而不会监视磁盘上等待处理的实际项目数。

所有规则都位于“ConfigMgr 2007 站点服务器 – 公用”处理安装类中，该类将这些规则应用于中央站点、主站点和辅助站点。

计划和可选配置

为尽量减少监视收件箱对性能造成的影响，将同步相关规则以便每天运行一次。这些规则从凌晨 01:00 开始，以 15 分钟的间隔错开，这样，一次只有一条规则在运行。例如，第一条规则于凌晨 01:00 对第一个收件箱中的文件进行计数。下一条规则于凌晨 01:15 对第二个收件箱中的文件进行计数，依此类推，直到完成对所有收件箱的计数。

您可以按照在 Operations Manager 2007 中计划要运行的规则脚本时通常采取的步骤来修改此计划。激活此功能不需要进行初始配置。以下是您可以执行的可选配置更改：

  • 更改每个收件箱的默认阈值。
  • 更改单个收件箱规则的计划。

可以按照在任何管理包中配置阈值事件规则时通常采取的步骤来更改这些可选配置。

阈值警报和阈值

只要在每次处理监视规则时达到为特定收件箱规则配置的阈值，就会生成一个警报。

编辑性能阈值

  1. 在 Operations Manager 2007 管理员控制台中，单击“创作”。

  2. 在“创作”窗格中，依次导航到“创作”>“管理包对象”>“监视器”。

  3. 在“监视器”窗格中，查找“ConfigMgr 服务器”。

  4. 导航到“ConfigMgr 服务器”>“Entity Health”>“可用性”，然后展开以下要编辑的服务器角色之一：

    • DB - 数据库服务器
    • DP - 分发点
    • FSP - 回退状态点
    • MP - 管理点服务器
    • PSP - PXE 服务点
    • SS - 站点服务器
    • Provider - 提供程序
    • RP - 报告点
    • SHV - 系统健康验证程序
    • SLP - 服务器定位器点
    • SMP - 状态迁移点
    • SUP - 软件更新点

  5. 右键单击要编辑其性能的监视器，导航到“替代”>“替代监视器”，然后单击受该替代影响的对象的类别。

  6. 选中相应复选框来配置监视器的“替代属性”，以满足您的环境要求。单击“确定”。

有关收件箱文件夹以及如何在配置管理器中使用它们的详细信息，请参阅网址为 http://go.microsoft.com/fwlink/?LinkId=99539 的网页（该链接可能指向英文页面）中有关介绍收件箱文件夹以及如何在配置管理器中使用它们的主题。

另请参阅

其他资源

部署 Configuration Manager 2007 管理包
Configuration Manager 2007 管理包参考


执行 Configuration Manager 2007 管理包操作任务

建议您及时查看和解决所有警报，以确定比较重要或可能比较严重的警报。此外，还应根据您的环境，定期执行其他任务。很多重要问题不会导致警报，但仍需要定期关注这些问题。System Center Configuration Manager 2007 管理包提供视图和报告，这些视图和报告按时间显示数据，并提供样式以提示出现的问题。请查看视图和报告以解决问题，避免生成警报。

应按本节中的说明，执行每日、每周和每月任务，但可以调整执行这些任务的频率，以满足特定环境的需要。

有关维护 Configuration Manager 2007 的详细信息，请参阅有关维护 Configuration Manager 2007 的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102324，该链接可能指向英文页面）。有关站点维护的详细信息，请参阅有关站点维护概述的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=102325，该链接可能指向英文页面）。

本节内容

Configuration Manager 2007 管理包的每日任务

Configuration Manager 2007 管理包的每周任务

Configuration Manager 2007 管理包的每月任务

另请参阅

概念

Configuration Manager 2007 管理包监视方案
Configuration Manager 2007 与 Operations Manager 2007 的集成

其他资源

Configuration Manager 2007 管理包概述
部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 管理包的每日任务

建议您每日执行下列任务：

  • 查看计算机组成员身份。
  • 验证是否所有 Operations Manager 2007 代理都在与 Operations Manager 2007 服务器通信。
  • 查看站点层次结构状态视图。
  • 查看站点状态视图。
  • 查看站点层次结构图。
  • 查看所有未解决的警报。使用运行状况资源管理器在任何一个视图或图表中查看明细。
  • 查看性能积压。
  • 查看性能处理速率。
  • 查看 Operations Manager 2007 代理和服务器性能。
  • 如果每天都要执行 ConfigMgr 站点备份，则需查看备份状态和备份文件。
  • 查看事件（可选）。

查看所有未解决的警报

在 Configuration Manager 2007 管理包中，很多警报都是以下列警报描述格式显示的：

$Computer$ <Rule Name>

$Description$

Event details

查看 Operations Manager 2007 中的所有警报以确保它们得到及时处理。您可以使用以下任一方式来查看未解决的警报：

  • 在操作控制台中，单击“监视”按钮，展开“Microsoft System Center Configuration Manager 2007”，然后单击“警报”。
  • 在操作控制台中，单击“监视”按钮，展开“Microsoft System Center Configuration Manager 2007”，然后单击“常规”。选择“最近 72 小时内的新警报”。
  • 可通过单击“创作模式”并选择“组”按计算机或计算机组来查看警报。右键单击要查看的 Configuration Manager 2007 计算机组，然后依次选择“状态视图”和“未解决的警报”。
  • 可通过“计算机状态”视图查看警报。该视图显示了计算机及其已发现的类的列表。右键单击任何计算机，然后选择“未解决的警报”视图，以获取按严重性设置优先级的当前警报的列表。
  • 可通过“站点状态”视图查看警报。“站点状态”视图显示了站点及其已发现的类的列表。右键单击任何站点，然后选择“未解决的警报”视图，以获取按严重性设置优先级的当前警报的列表。
  • 可通过“站点层次结构状态”视图查看警报。“站点层次结构状态”视图显示了站点层次结构及其已发现的类的列表。右键单击相关层次结构实例，然后选择“未解决的警报”视图，以获取按严重性设置优先级的当前警报的列表。
  • 可通过“站点层次结构图”视图查看警报。“站点层次结构图”视图显示了以图形表示的 Configuration Manager 2007 站点层次结构。右键单击显示在该图中的任何对象，然后选择“未解决的警报”视图，以获取按严重性设置优先级的当前警报的列表。

建议您按下列顺序查看所有新增警报：

  1. Configuration Manager 2007 安装失败警报
  2. Configuration Manager 2007 核心服务警报
  3. Configuration Manager 2007 从属服务警报
  4. Configuration Manager 2007 脚本错误警报
  5. Configuration Manager 2007 服务器角色警报
  6. Configuration Manager 2007 组件警报
  7. 基于 Configuration Manager 2007 站点系统状态摘要生成器的警报
  8. 基于 Configuration Manager 2007 状态消息的警报
  9. Configuration Manager 2007 性能阈值警报
  10. Configuration Manager 2007 收件箱监视警报
  11. Configuration Manager 2007 发件箱监视警报
  12. Configuration Manager 2007 任务监视警报
  13. Configuration Manager 2007 站点备份失败警报
  14. Configuration Manager 2007 程序失败警报

查看计算机组成员身份

可使用 Operations Manager 2007 来验证计算机组成员身份。

在操作控制台中，单击“创作”按钮，单击“组”，然后右键单击相应的 Microsoft Configuration Manager 2007 计算机组。验证所显示的每个计算机组是否包含正确的计算机。

验证代理是否在与 Operations Manager 2007 服务器通信

如果代理与监视基础结构之间通信失败，将无法接收警报。通过验证“计算机状态”视图中的配置管理器服务器的健康状况是否灰显，来验证代理是否在与运行 Operations Manager 2007 的服务器进行通信。

查看性能积压和性能处理速率

性能积压和性能处理速率对于检测每日趋势和了解配置管理器层次结构中发生的事件非常有用。可在 Operations Manager 2007 中查看性能积压和性能处理速率。

查看性能积压

要查看性能积压，请执行下列步骤：

查看性能积压

  1. 在操作控制台中，单击“监视”按钮，然后展开“Microsoft System Center Configuration Manager 2007”。

依次展开“性能”、“积压”。然后，单击相应的服务器角色子文件夹和视图。单击“显示”按钮，以指定显示在计数器图中的计算机。

查看性能处理速率

要查看性能处理速率，请执行下列步骤：

查看性能处理速率

  1. 在操作控制台中，单击“监视”按钮，然后展开“Microsoft System Center Configuration Manager 2007”。

  2. 依次展开“性能”和“处理速率”。然后，单击相应的服务器角色子文件夹和视图。单击“显示”复选框，以指定显示在计数器图中的计算机。

查看性能条件

要查看性能条件，请执行下列步骤：

查看性能条件

  1. 在操作控制台中，单击“监视”按钮，然后展开“Microsoft System Center Configuration Manager 2007”。

  2. 依次展开“性能”、“条件”。然后，单击相应的服务器角色子文件夹和视图。选中“显示”复选框，以指定要显示在计数器图中的计算机。

Configuration Manager 2007 备份监视

应根据需要在您的企业环境中启用 Configuration Manager 2007 站点备份维护任务并计划备份。配置管理器站点备份过程支持 VSS，但不支持在以下过程中执行运行时备份：

  • 将配置管理器安装文件夹的部分内容复制到备份导出路径
  • 备份各种配置管理器注册表值
  • 在运行 Microsoft SQL Server™ 的服务器上备份配置管理器站点数据库

备份完成后，配置管理器站点备份服务将重新启动 SMS 服务。在备份过程中，这些服务停止和启动是正常的，并不表示发生了任何严重错误。在配置管理器站点备份过程中，将会抑制这些已停止的服务通常情况下会引发的警报，因为备份过程将暂停 MOM 代理，实际上就是将其置于代理维护模式。要关联站点备份的启动和完成，应启用下列规则，这些规则可在 SMS 站点备份服务启动或停止时引发信息警报：

  • ConfigMgr 2007 服务已停止运行:SMS_SITE_BACKUP
  • ConfigMgr 2007 服务已开始运行:SMS_SITE_BACKUP

当配置管理器站点备份服务无法启动或异常停止时，将引发下列警报：

  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 异常终止
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 在启动时挂起
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 无法启动
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 无法登录
  • ConfigMgr 2007 服务故障:SMS_SITE_BACKUP 依赖于另一服务，但该服务无法启动或不存在

如果您看到一条指示服务异常终止的警报，请验证是否已重新启动所有停止的服务。配置管理器站点备份服务可能在重新启动这些服务之前已经终止。

下面的状态消息警报显示备份过程是否成功：

  • ConfigMgr 2007 状态:站点备份成功完成
  • ConfigMgr 2007 状态:站点备份失败
  • ConfigMgr 2007 状态:在当前备份任务完成后，Site Backup 才能开始执行备份过程
  • ConfigMgr 2007 状态:Site Backup 发现 SQL 备份路径为空或无效

引发失败警报的原因可能包括：访问权限问题、磁盘空间不足、无法启动或停止某些服务或者 SQL Server 操作失败。

查看事件

建议您定期查看事件，因为它们指示了非关键性的失败，并有助于深入了解 Operations Manager 2007 代理的运行状况。

查看事件

要查看事件，请执行下列步骤：

查看事件

  1. 在操作控制台中，单击“监视”按钮。

  2. 展开“Microsoft System Center Configuration Manager 2007”，然后单击“事件”。

另请参阅

概念

Configuration Manager 2007 与 Operations Manager 2007 的集成
Configuration Manager 2007 管理包监视方案

其他资源

Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 管理包的每周任务

除了每天执行的任务外，还可以按周执行以下任务：

  • 查看报告。有关 Configuration Manager 2007 管理包中包含的报告的列表，请参阅本指南中的 Configuration Manager 2007 管理包的报告一节。
  • 查看过去一周的警报、事件、服务器可用性、配置更改和性能，以发现潜在问题和趋势。
  • 如果需要，请调整 Operations Manager 2007 的配置设置，例如 Operations Manager 2007 代理的检测信号间隔、警报设置以及数据库整理参数。
  • 查看 Configuration Manager 2007 站点的备份历史记录。
  • 查看 Configuration Manager 2007 的 Operations Manager 2007 配置组的备份历史记录。
  • 查看 SQL Server 数据库和日志。
  • 运行 Configuration Manager 2007 的可用性报告，以获取 Configuration Manager 2007 服务器及其角色的可用性情况。
  • 使用 Configuration Manager 2007 站点层次结构图验证 Configuration Manager 2007 的层次结构。

另请参阅

概念

Configuration Manager 2007 管理包的每日任务
Configuration Manager 2007 管理包的每月任务

其他资源

Configuration Manager 2007 管理包疑难解答
Configuration Manager 2007 管理包参考


Configuration Manager 2007 管理包的每月任务

除每天和每周执行的任务之外，还需每月检查下列类别的数据：

  • 查看通知订阅和收件人。验证是否为每个订阅选择相应的组和类。

最常见的警报和事件

  • 最常见的警报
  • 最常见的事件
  • 最常见的警报和事件（按计算机和类）
  • 最常见的警报和事件（按 Configuration Manager 2007 组件）
  • 最常见的警报和事件（按 Configuration Manager 2007 服务器角色）

可以制定一个操作计划来减少警报数和事件数。

Configuration Manager 2007 积压监视

查看各种站点系统上与积压趋势相关的性能原始报告。

Configuration Manager 2007 积压趋势

查看与原始性能和速率性能相关的报告，以确保在 Configuration Manager 2007 站点系统上积压数没有呈现长期向上的趋势，并且不存在影响服务级别协议 (SLA) 的不可接受水平的积压。查看以下内容：

  • 发现数据记录
  • 硬件清单
  • 软件清单
  • 软件计数
  • 状态消息
  • 状态消息

常规系统性能

查看服务器系统资源性能报告，以针对下列各项内容来检查系统性能：

  • 磁盘使用
  • 内存使用
  • 处理器使用

服务器角色性能

查看以下每个角色的原始性能报告和速率性能报告：

  • 设备管理点
  • 管理点
  • 站点服务器

Configuration Manager 2007 可用性

运行 Configuration Manager 2007 的可用性报告，以了解 Configuration Manager 2007 服务器和 Configuration Manager 2007 服务器角色的可用性。

Configuration Manager 2007 站点层次结构监视

查看配置管理器站点层次结构中的代理安装情况，并确定对已部署的服务器执行的监视的涵盖范围是否充分。可能已部署尚未安装 MOM 代理的新配置管理器服务器。

另请参阅

概念

Configuration Manager 2007 管理包的每日任务
Configuration Manager 2007 管理包的每周任务
Configuration Manager 2007 与 Operations Manager 2007 的集成

其他资源

执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包参考
Configuration Manager 2007 管理包疑难解答


Configuration Manager 2007 管理包疑难解答

您可以采取许多措施来解决产品问题：

  • 确保已正确安装 Operations Manager 2007。
  • 确保已正确设置 Operations Manager 2007 配置设置。
  • 确保通过 Operations Management 注册表项正确配置了所有 System Center Configuration Manager 2007 系统。
  • 确保所有托管的 Configuration Manager 2007 提供程序和 Configuration Manager 2007 站点服务器计算机都已安装 Operations Manager 2007 代理，并已启用为其他计算机的代理。
  • 确保已成功导入完整的管理包。
  • 确保已启用所有相关实体，如规则和监视器。
  • 确保计算机组由正确的计算机组成。在控制台中，可以使用创作模式组节点来执行此检查。
  • 确保所有代理都能正常运行。
  • 确保已正确设置检测信号间隔，并已将规则传播到 Operations Manager 2007 代理计算机。
  • 确保 Windows 管理规范 (WMI)、World Wide Web 发布服务、Internet Information Services (IIS) 管理服务、后台智能传输服务 (BITS)、Windows Server Update Services (WSUS)、Windows 部署服务服务器 (WDS)、Trivial FTP Daemon (TFTPD) 和 MSSQLServer 等从属服务都已在 Configuration Manager 2007 站点系统上正确安装并正常运行。
  • 确保已正确安装所有性能计数器。
  • 确保在操作帐户不是本地系统帐户的情况下脚本拥有足够权限来访问所需的资源。

本节内容

Configuration Manager 2007 管理包的已知问题

另请参阅

概念

Configuration Manager 2007 管理包监视方案

其他资源

Configuration Manager 2007 管理包概述
部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务
Configuration Manager 2007 管理包参考


Configuration Manager 2007 管理包的已知问题

下面是有关用于 Operations Manager 2007 的 Configuration Manager 2007 管理包的已知问题。

Configuration Manager 2007 可能影响终止 WMI 服务的非 Microsoft 软件的安装

WMI 监视

如果在同一台计算机上安装了 SMS 管理员控制台，Configuration Manager 2007 管理包无法检测到 SMS 辅助站点

系统重新启动可提供有限警报

Configuration Manager 2007 Monitor SMS Status Messages 脚本

Configuration Manager 2007 Monitor Site Summarizer 脚本偏离默认站点系统状态摘要生成器间隔

默认情况下，BITS 监视是禁用的

应用程序提供程序的路径默认设为 SMS_INSTALL_DIR_PATH% \ Logs，此路径可能对任何配置管理器站点服务器都无效

监视发送程序连接性的状态消息规则依赖于发送程序的功能

站点拓扑视图中的脚本错误描述了安装路径而不是计算机名称

所有配置管理器服务器上都需要代理才能提供站点层次结构图支持

Configuration Manager 2007 状态视图中显示 SMS 2003 任务

配置管理器可能影响终止 WMI 服务的非 Microsoft 软件的安装

Configuration Manager 2007 管理包可能会影响需要访问 Windows 管理规范 (WMI) 服务的非 Microsoft 软件的安装。管理包的大多数脚本使用 WMI 来访问注册表，并可以重新启动 WMI 服务。如果 WMI 服务已启用并且可以启动，则组件对象模型 (COM) 可以成功重新启动 WMI。

如果非 Microsoft 软件停止，但未在安装或升级过程中禁用 WMI，则 WMI 脚本的自动重新启动可能会影响非 Microsoft 软件的成功安装。在安装程序未先禁用 WMI 服务的情况下，这可能导致 WMI 或 WMI 提供程序升级出现问题。此问题适用于 WMI 的任何客户端。

WMI 监视

  • 以下规则基于服务控制管理器的 Windows NT® 系统事件日志来监视意外的服务故障。对于这些规则，无任何已知的操作系统限制。
  • Configuration Manager 2007 从属服务故障:Windows 管理规范异常终止。
  • Configuration Manager 2007 从属服务故障:Windows 管理规范在启动时挂起。
  • Configuration Manager 2007 从属服务故障:Windows 管理规范无法启动。
  • Configuration Manager 2007 从属服务故障:Windows 管理规范无法登录。
  • Configuration Manager 2007 从属服务故障:Windows 管理规范依赖于另一服务，但该服务无法启动或不存在。

如果在同一台计算机上安装了 ConfigMgr 2007 管理员控制台，Configuration Manager 2007 管理包无法检测到辅助站点

如果在同时作为 Configuration Manager 2007 辅助站点服务器的计算机上安装 Configuration Manager 2007 管理员控制台，则 Configuration Manager 2007 管理包无法将该服务器识别为 Configuration Manager 2007 辅助站点服务器。

为解决此问题，在 Configuration Manager 2007 辅助站点服务器上安装 Configuration Manager 2007 管理员控制台后，需要将注册表值 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type 由 4 更改为 2。

系统重新启动可提供有限警报

系统重新启动时，您可能只会收到几条有关服务停止的警报。不会有任何事件或警报指明系统被重新启动。检测系统正常或异常关闭的最佳解决方案是安装 Microsoft Windows Servers 基础操作系统管理包，其中包含的规则可提示您系统重新启动。确定系统是否重新启动的其他方法包括查看 Configuration Manager 2007 日志、Operations Manager 2007 NT 事件日志、Windows NT 事件日志以及 Operations Manager 2007 事件中的代理通信。

Configuration Manager 2007 Monitor SMS Status Messages 脚本

当 Configuration Manager 2007 状态消息表中的消息数超过 4,294,967,296 条时，记录 ID 将从零重新开始。Configuration Manager 2007 Monitor SMS Status Messages 脚本没有检测机制来检测记录 ID 何时从零重新开始。目前，该脚本只是从它所处理的最后一条状态消息的记录 ID 开始向前查找。如果该记录 ID 重新开始，则管理包无法检测到任何新的状态消息。

在站点服务器上，记下“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER”注册表项中的 Next Status Message Record ID 注册表值。该值是位于 SQL StatusMessages 表中的下一条记录 ID。如果该值小于 LastRecordID 值，则表示 StatusMessages 表已循环并重新开始。在 Next Status Message Record ID 注册表值大于 VarSet 文件中的 LastRecordID 值后，该脚本才会重新开始处理消息。

您应该定期监视站点服务器上的 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 注册表项中下一条状态消息的记录 ID。在 SMS 层次结构中处于较低层次的小型组织或站点应每隔一两个月检查一次该注册表项。具有多个子站点的大型组织或站点应每月检查一次该注册表项。如果值接近 4,294,967,296，则应更频繁地监视该注册表项。当记录 ID 重置为零后，必须取消阻止对运行站点服务器的计算机进行状态消息监视。

自动监视注册表项的一种方法是，为接近此阈值的计算机创建一个脚本或发现规则。

要找到配置组中的所有 Configuration Manager 2007 站点数据库，请执行下列步骤。请注意，现在，站点数据库服务器角色实际上是在站点服务器上的 ConfigMgr 中发现的，以便支持群集 SQL Server。

步骤

找到配置组中的所有 Configuration Manager 2007 站点数据库并取消阻止状态消息监视

  1. 在操作控制台中，单击“创作”按钮，然后选择“组”。

  2. 在结果窗格中，搜索包含“Microsoft ConfigMgr 2007 站点数据库服务器计算机组”的组名。

  3. 右键单击要查找的成员的组名，然后选择“查看组成员”。

  4. 在承载 Configuration Manager 2007 站点数据库角色的计算机上，打开运行脚本的用户上下文的 TMP 环境变量所指定的路径（如果是本地系统，则为 Windows Temp 文件夹）中的以下文本文件：ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet。LastRecordID_[SMSDatabaseName] 条目是指明 SQL StatusMessages 表中脚本所处理的最后一条状态消息的记录 ID 值。

  5. 将 LastRecordID_[SMS 数据库名称] 值更改为等于 Next Status Message Record ID 注册表值减一。如果结果为 4,294,967,296，请将该值设置为零并保存文件。

Configuration Manager 2007 Monitor Site Summarizer 脚本偏离默认站点系统状态摘要生成器间隔

站点系统状态摘要生成器每隔一小时正点轮询一次，Configuration Manager 2007 Monitor Site System Summarizer 脚本的间隔则与此轮询间隔偏离 10 分钟。虽然配置管理器管理员控制台允许配置站点系统状态摘要生成器计划，但它不会更改此轮询间隔，而只会更改其他维护任务的间隔。配置管理器中的 Monitor Site System Summarizer 脚本是以“每 60 分钟，于以下时间同步: 00:10”的方式运行的。通过偏离 10 分钟，可以留出足够的时间让站点系统状态摘要生成器完成其运行周期。如果这段时间不够，应予以延长，否则该脚本将在站点系统摘要生成器完成其运行周期之前完成。这可能会导致报告旧的站点系统状态。

默认情况下，BITS 监视是禁用的

因为后台智能传输服务 (BITS) 是应 Configuration Manager 2007 客户端的要求启动的，所以默认情况下，在配置管理器管理包中将禁用以下规则：

  • ConfigMgr 2007 从属服务运行:后台智能传输服务

如果您将此服务配置为自动启动，则应启用此规则。

默认情况下，应启用下列规则以监视 BITS 服务的问题，并在 SMS 代理主机无法根据需要启动 BITS 服务时进行报告：

  • ConfigMgr 2007 服务故障:后台智能传输服务异常终止。
  • ConfigMgr 2007 服务故障:后台智能传输服务在启动时挂起。
  • ConfigMgr 2007 服务故障:后台智能传输服务无法启动。
  • ConfigMgr 2007 服务故障:后台智能传输服务无法登录。
  • ConfigMgr 2007 服务故障:后台智能传输服务依赖于另一服务，但该服务无法启动或不存在。

应用程序提供程序的路径默认设为 SMS_INSTALL_DIR_PATH% \ Logs，此路径可能对任何 SMS 站点服务器都无效

以下组件规则使用应用程序日志：

  • ConfigMgr 2007 组件:发送程序无法通过 LAN (标准安全)连接到远程站点。
  • ConfigMgr 2007 组件:发送程序无法通过 RAS 连接到远程站点。
  • ConfigMgr 2007 组件:发送程序无法通过 LAN (高级安全)连接到远程站点。
  • ConfigMgr 2007 组件:分发管理器无法处理数据包。
  • ConfigMgr 2007 组件:分发管理器无法插入 SMS 数据包，因为 CI_Contents 表中没有 SDM 类型内容。
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的软件更新策略。
  • ConfigMgr 2007 组件:策略提供程序无法创建新的软件更新策略。
  • ConfigMgr 2007 组件:策略提供程序无法从 SMS 站点数据库获取新的相容性策略。
  • ConfigMgr 2007 组件:策略提供程序无法创建新的相容性策略。
  • ConfigMgr 2007 组件:策略提供程序无法向层次结构管理器通知策略更改

要使这些规则发挥作用，您需要在站点服务器上使用为您的站点安装指定的安装路径来创建 %SMS_INSTALL_DIR_PATH% 环境变量。该环境变量路径不能以反斜杠结尾。每个具有发送程序的 Configuration Manager 2007 服务器必须是托管计算机。

默认情况下，会启用除了“ConfigMgr 2007 组件:分发管理器无法处理数据包”之外的所有规则。

监视发送程序连接性的状态消息规则依赖于发送程序的功能

如果发送程序无法连接到其父站点，则状态消息无法向上流动到配置管理器层次结构，管理包不会为这些状态消息生成警报。这对于辅助站点尤为重要，辅助站点不运行 ConfigMgr 2007 Monitor Status Message 脚本。下列监视发送程序连接性的状态消息规则依赖于发送程序的功能，默认情况下，这些规则是禁用的：

  • ConfigMgr 2007 状态:发送程序无法通过 LAN (标准安全)连接到远程站点。
  • ConfigMgr 2007 状态:发送程序无法通过 RAS 连接到远程站点。
  • ConfigMgr 2007 状态:发送程序无法通过 LAN (高级安全)连接到远程站点。
注意
默认情况下，所有这些规则都是禁用的。为使这些规则起作用，每一台 SMS 站点数据库服务器或者至少中央站点必须是托管计算机。

根据 Configuration Manager 2007 发送程序日志，已提供了一种并行监视方法。默认情况下，这些规则是启用的。如果您禁用这些规则，则应考虑启用上述状态消息规则。请勿同时启用这两组规则，否则会导致生成重复警报。无法合并这些事件或警报规则来处理状态消息和组件规则同时处于活动状态的情况。

  • ConfigMgr 2007 组件:发送程序无法通过 LAN (标准安全)连接到远程站点。
  • ConfigMgr 2007 组件:发送程序无法通过 RAS 连接到远程站点。
  • ConfigMgr 2007 组件:发送程序无法通过 LAN (高级安全)连接到远程站点。

要使这些规则发挥作用，您需要在站点服务器上使用为您的站点安装指定的安装路径来创建 %SMS_INSTALL_DIR_PATH% 环境变量。该环境变量路径不能以反斜杠结尾。同时，每个具有发送程序的配置管理器服务器必须是托管计算机。有关详细信息，请参阅应用程序提供程序的路径默认设为 SMS_INSTALL_DIR_PATH% \ Logs，此路径可能对任何配置管理器站点服务器都无效。

站点层次结构发现视图中的脚本错误描述了安装路径而不是计算机名称

查看来自 ConfigMgr 2007 Site Hierarchy Discovery 脚本或本地创建的规则中的脚本错误时，生成错误的计算机的安装类被描述为“源”。生成错误的计算机的计算机名称被描述为该脚本错误的“警报描述”或“路径”的一部分。

所有配置管理器服务器上都需要代理才能提供站点层次结构图支持

要使站点层次结构图能够发挥作用，必须在站点中的所有配置管理器服务器（包括承载该站点数据库的任何远程 SQL Server）上本地安装代理。这适用于所有受监视的站点，包括中央站点、主站点和辅助站点。

Configuration Manager 2007 状态视图中显示 SMS 2003 任务

如果安装了 System Management Server (SMS) 2003 和 Configuration Manager 2007 管理包，则 SMS 2003 任务将显示在 Configuration Manager 2007 状态视图中，因为将对 Windows Computer 类（而不是 SMS Server 类）执行 SMS 2003 任务。

另请参阅

概念

支持的 Configuration Manager 2007 管理包配置

其他资源

Configuration Manager 2007 管理包疑难解答
Configuration Manager 2007 管理包概述
Configuration Manager 2007 管理包参考


Configuration Manager 2007 管理包参考

以下参考资料提供了 Operations Manager 2007 和 Configuration Manager 2007 的相关指南。

本节内容

Configuration Manager 2007 管理包的其他资源

Configuration Manager 2007 管理包的站点和组件

Configuration Manager 2007 管理包的计算机组

Configuration Manager 2007 管理包的安装类

Configuration Manager 2007 管理包的脚本

Configuration Manager 2007 管理包的视图

Configuration Manager 2007 管理包的图表

Configuration Manager 2007 管理包的报告

另请参阅

概念

Configuration Manager 2007 管理包监视方案

其他资源

Configuration Manager 2007 管理包概述
部署 Configuration Manager 2007 管理包
执行 Configuration Manager 2007 管理包操作任务


Configuration Manager 2007 管理包的其他资源

下列资源可供 System Center Configuration Manager 2007 管理包使用。

Microsoft Operations Manager 2007

要访问 Internet 上的 Operations Manager 2007 核心产品文档以及获得有关 System Center Operations Manager 2007 的最新信息，请访问 Operations Manager 2007 产品网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。

System Center Configuration Manager 2007

核心产品文档、Configuration Manager 2007 管理员控制台帮助、Configuration Manager 2007 术语表以及 Configuration Manager 2007 联机库中提供了部署和使用 Configuration Manager 2007 所需的全部信息。通过 Configuration Manager 2007 管理员控制台，可以访问 Configuration Manager 2007 文档库和 Configuration Manager 2007 管理员控制台帮助。

Configuration Manager 2007 联机库

  • Configuration Manager 2007 文档库说明了有关部署和使用 Configuration Manager 2007 所需的信息。该文档库是随 Configuration Manager 2007 一起安装的。

Web 上的 Configuration Manager 2007

  • 有关 Configuration Manager 2007 的最新信息，请访问配置管理器文档库的相关网页（网址为：http://go.microsoft.com/fwlink/?LinkId=98803，该链接可能指向英文页面）。
  • 若要获取进一步的帮助，请参阅配置管理器网站上有关针对配置管理器的支持（http://go.microsoft.com/fwlink/?LinkId=98800，该链接可能指向英文页面）的支持部分中其他支持选项的列表。
  • 要搜索 Microsoft 知识库和其他技术资源，以便快速、准确地找到解决 SMS 问题的方法，请访问 Microsoft 客户帮助和支持网站。可以使用为特定问题分配的“Qxxxxxx”编号或“xxxxxx”编号查询知识库，以便找到有关该问题的文章。

提供反馈

  • 您可以给我们发送反馈和意见，帮助 Configuration Manager 2007 文档组为您提供您最需要的产品信息。请将有关文档的反馈发送至配置管理器。

另请参阅

概念

Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的站点和组件

系统中心配置管理器组件包括配置管理器中央站点服务器、配置管理器站点数据库和配置管理器管理员控制台。通常，配置管理器中央站点服务器、配置管理器站点数据库和配置管理器管理员控制台驻留在同一台服务器上，而每个站点系统角色驻留在专用服务器上。中央站点服务器与数据库，以及任何站点系统角色，组成了一个配置管理器站点。一个配置管理器站点可能包含多个重复的站点系统角色。Configuration Manager 2007 站点可以分层。一个配置管理器站点可能不包含某些站点服务器角色，如服务器定位器点。

Configuration Manager 2007 管理包可用于监视配置管理器站点层次结构以及其中的服务器，但不用于监视配置管理器客户端计算机上的配置管理器功能。但是，Operations Manager 2007 可用于监视驻留在配置管理器客户端计算机上的其他应用程序。

有关 Configuration Manager 2007 组件的详细信息，请参阅配置管理器联机库。有关配置管理器文档的链接，请参阅本指南中的 Configuration Manager 2007 管理包的其他资源一节。

关键的服务器角色包括：

  • 分发点
  • 管理点
  • 服务器定位器点
  • 报告点
  • 软件更新点
  • 站点服务器
  • 站点数据库
  • 配置管理器提供程序
  • 移动设备管理点
  • 配置管理器管理员控制台
  • 回退状态点
  • PXE 服务点
  • 系统健康验证程序点
  • 服务器定位器点
  • 状态迁移点

分发点

在安装由配置管理器分发的软件程序时，分发点将存储配置管理器客户端所使用的配置管理器数据包源文件。在配置管理器管理员播发程序时，客户端可通过管理点获取播发和程序信息。

在设置配置管理器时，将为站点服务器自动分配分发点角色。配置管理器管理员可以启用分发点，以便使用后台智能传输服务 (BITS)，这样可以将增量数据包文件下载到客户端。

客户端使用 BITS 来自动检测客户端网络的连接能力，并有效地调整传输速率。只有运行 Microsoft Windows XP Professional、Microsoft Windows Server™ 2003 操作系统和 Windows Vista 操作系统的客户端才支持此功能。

管理点

管理点是配置管理器客户端和配置管理器站点服务器之间的主要联系点。一个配置管理器站点只有一个默认管理点，尽管可以通过 Windows 网络负载平衡服务来配置多个管理点。管理点：

  • 在安装客户端之后为客户端提供特定客户端配置详细信息。
  • 作为客户端计算机检查播发的位置。
  • 为客户端定位分发点。
  • 从客户端接收清单、软件计数和状态信息，并将其转发到配置管理器站点服务器。

服务器定位器点

服务器定位器点可为配置管理器客户端定位管理点。服务器定位器点大多用于客户端安装过程中。服务器定位器点可提供以下功能：

  • 为客户端定位管理点（如果为客户端配置了自动分配配置管理器站点）。
  • 在由登录脚本启动的客户端安装和凭据不足的安装中，为客户端提供管理点的位置。

报告点

报告点是运行 Internet Information Services (IIS) 的服务器，该服务器承载报告查看器和任何附加报告的代码。报告点只与其配置管理器站点数据库服务器进行通信。

软件更新点

Configuration Manager 2007 中的软件更新点是软件更新的必需组件，是作为配置管理器控制台中的站点系统角色来安装的。必须在安装了 Windows Server Update Services (WSUS) 3.0 并可与 WSUS 组件交互的站点系统服务器上创建软件更新点站点系统角色，才能配置更新设置、请求与上游更新服务器同步，以及将 WSUS 数据库中的更新同步到站点服务器数据库。

要为软件更新点和 Windows Server Update Services 启用监视，请执行下列步骤。

为软件更新点和 Windows Server Update Services 启用监视

  1. 在操作控制台中，单击“创作”。

  2. 在“导航”窗格中，导航到“创作”>“管理包对象”，然后单击“规则”。

  3. 在“规则”窗格中，搜索要启用的规则。如果规则列表上的“查找”栏不可用，请导航到“视图”，然后单击“查找”。

  4. 右键单击要启用的规则的规则名，然后导航到“替代”>“替代规则”，然后单击要由该规则监视的对象集。

  5. 将“已启用”设置为“真”，然后根据环境的需要来修改任意阈值。单击“确定”。

站点服务器

分配给成功运行了配置管理器安装程序的服务器的配置管理器站点系统角色。如果某台计算机上安装了配置管理器站点，则系统会向该计算机自动分配站点服务器角色。每一个配置管理器站点都有一个站点服务器。

站点数据库

分配给承载配置管理器站点数据库（SQL Server 数据库））的计算机的配置管理器站点系统角色。

配置管理器提供程序

配置管理器提供程序负责处理从配置管理器站点数据库获取数据的请求。配置管理器提供程序角色与配置管理器站点服务器或配置管理器站点数据库安装在同一台计算机上。建议将配置管理器提供程序和配置管理器站点数据库都安装在站点服务器上。配置管理器提供程序可为安装在站点上的配置管理器管理员控制台提供数据访问。

移动设备管理点

设备管理点是依赖于 Configuration Manager 2007 管理点角色的站点角色。设备管理点是 Configuration Manager 2007 Windows Mobile 设备客户端的通信点，必须驻留在 Configuration Manager 2007 管理点所在的计算机上。

配置管理器管理员控制台

Configuration Manager 2007 管理员控制台是用于管理配置管理器的图形用户界面。该界面使用随配置管理器产品软件提供的 Microsoft 管理控制台 (MMC) 管理单元。在安装主站点服务器时，将默认安装配置管理器管理员控制台。也可以将其安装在其他服务器或工作站上。

回退状态点

一种配置管理器站点系统角色，用于收集来自以下客户端的状态消息：无法正确安装的客户端、无法向 Configuration Manager 2007 站点分配角色的客户端，或无法找到所分配的管理点或与之进行通信的客户端。客户端安装和分配成功时，也会将状态消息发送到回退状态点。

PXE 服务点

Configuration Manager 2007 使用 PXE 服务点站点角色来启动操作系统部署过程。PXE 服务点必须配置为可响应由网络上的 Configuration Manager 2007 客户端发出的 PXE 启动请求，并且随后可与 Configuration Manager 2007 基础结构交互以确定要执行的相应部署操作。

系统健康验证程序点

系统健康验证程序点是运行在充当网络策略服务器 (NPS) 角色的 Windows Server 2008 上的 Configuration Manager 2007 站点系统角色。在 Configuration Manager 2007 中使用网络访问保护 (NAP) 时，需要系统健康验证程序点来验证具有 NAP 功能的配置管理器客户端发出的健康声明，以生成相容或不相容的客户端健康状况，或验证是否存在无法确定健康状况的错误情况。

服务器定位器点

服务器定位器点用来在 Configuration Manager 2007 层次结构中完成 Intranet 上的客户端站点分配，并在客户端无法通过 Active Directory 域服务找到管理点信息时帮助其找到管理点。Intranet 客户端将 Active Directory 域服务用作完成站点分配和查找管理点的首选方法。但是，如果没有针对 Configuration Manager 2007 扩展 Active Directory 架构，或未将站点发布到 Active Directory 域服务，或客户端不属于站点服务器的林所在的 Active Directory 林，则客户端必须使用服务器定位器点。

状态迁移点

在部署操作系统映像的过程中，在两台计算机之间迁移用户状态和设置时，Configuration Manager 2007 操作系统部署会使用状态迁移点。状态迁移点需要安装 Internet Information Services。

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的计算机组

Configuration Manager 2007 管理包提供了下列计算机组：

  • Microsoft ConfigMgr 2007 管理员控制台 - 安装有管理员控制台的 ConfigMgr 2007 站点系统、成员服务器或工作站。
  • Microsoft ConfigMgr 2007 高级客户端 - 安装在任意系统上的 ConfigMgr 2007 高级客户端。
  • Microsoft ConfigMgr 2007 分支分发点服务器 - 用作分支分发点服务器的 ConfigMgr 2007 客户端。
  • Microsoft ConfigMgr 2007 中央站点服务器 - 用作中央站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 客户端 - 安装有 ConfigMgr 2007 客户端的 ConfigMgr 2007 计算机。
  • 基于 IIS 的 Microsoft ConfigMgr 2007 组件服务器 - 运行 IIS 服务的 ConfigMgr 2007 站点服务器或站点系统。
  • 基于 SMS Executive 的 Microsoft ConfigMgr 2007 组件服务器 - 运行 SMS Executive 服务的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 设备管理点服务器 - 用作设备管理点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 分发点服务器 - 用作分发点服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 回退状态点服务器 - 安装有 ConfigMgr 回退状态点的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 管理点服务器 - 用作管理点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 主站点服务器 - 用作主站点服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 提供程序 - 用作 ConfigMgr 提供程序的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 PXE 服务器 - 用作安装有 ConfigMgr PXE 服务点的 Windows 部署服务服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 报告点服务器 - 用作报告点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 辅助站点服务器 - 用作辅助站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 服务器定位器点服务器 - 用作服务器定位器点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 服务器 - ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 站点数据库服务器 - 用作站点数据库服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 站点服务器 - 用作主站点服务器或辅助站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 软件更新点服务器 - 用作安装有 ConfigMgr 软件更新点的 Windows Software Update Services 服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 标准分发点服务器 - 用作标准分发点服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 状态迁移点服务器 - 安装有 ConfigMgr 状态迁移点的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 系统健康验证程序服务器 - 用作安装有 ConfigMgr 系统健康验证程序的 Internet 验证服务器的 ConfigMgr 2007 站点系统。

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的安装类

本节列出了应用规则和监视器等对象的 System Center Configuration Manager 2007 管理包中的安装类。请参阅 Operations Manager 2007 操作控制台中的“创作”，然后将作用域设置为所需的特定类。

  • Microsoft ConfigMgr 2007 管理员控制台 - 安装有管理员控制台的 ConfigMgr 2007 站点系统、成员服务器或工作站。
  • Microsoft ConfigMgr 2007 高级客户端 - 安装在任意系统上的 ConfigMgr 2007 高级客户端。
  • Microsoft ConfigMgr 2007 分支分发点服务器 - 用作分支分发点服务器的 ConfigMgr 2007 客户端。
  • Microsoft ConfigMgr 2007 中央站点服务器 - 用作中央站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 客户端 - 安装有 ConfigMgr 2007 客户端的 ConfigMgr 2007 计算机。
  • 基于 IIS 的 Microsoft ConfigMgr 2007 组件服务器 - 运行 IIS 服务的 ConfigMgr 2007 站点服务器或站点系统。
  • 基于 SMS Executive 的 Microsoft ConfigMgr 2007 组件服务器 - 运行 SMS Executive 服务的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 设备管理点服务器 - 用作设备管理点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 分发点服务器 - 用作分发点服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 回退状态点服务器 - 安装有 ConfigMgr 回退状态点的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 管理点服务器 - 用作管理点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 主站点服务器 - 用作主站点服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 提供程序 - 用作 ConfigMgr 提供程序的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 PXE 服务器 - 用作安装有 ConfigMgr PXE 服务点的 Windows 部署服务服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 报告点服务器 - 用作报告点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 辅助站点服务器 - 用作辅助站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 服务器定位器点服务器 - 用作服务器定位器点的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 服务器 - ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 站点数据库服务器 - 用作站点数据库服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 站点服务器 - 用作主站点服务器或辅助站点服务器的 ConfigMgr 2007 站点服务器。
  • Microsoft ConfigMgr 2007 软件更新点服务器 - 用作安装有 ConfigMgr 软件更新点的 Windows Software Update Services 服务器的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 标准分发点服务器 - 用作标准分发点服务器的 ConfigMgr 2007 站点服务器或站点系统。
  • Microsoft ConfigMgr 2007 状态迁移点服务器 - 安装有 ConfigMgr 状态迁移点的 ConfigMgr 2007 站点系统。
  • Microsoft ConfigMgr 2007 系统健康验证程序服务器 - 用作安装有 ConfigMgr 系统健康验证程序的 Internet 验证服务器的 ConfigMgr 2007 站点系统。

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的脚本

Configuration Manager 2007 管理包中包含在代理上自动运行的 Operations Manager 2007 脚本以及需要由管理员运行的脚本。本节以下部分将介绍其中某些脚本的详细信息。

下列脚本由 Operations Manager 2007 代理自动运行：

  • ConfigMgr 2007 Monitor Collection Evaluation Tasks
  • ConfigMgr 2007 Monitor Component Health
  • ConfigMgr 2007 Monitor NLB Management Point Health
  • ConfigMgr 2007 Monitor Server Health
  • ConfigMgr 2007 Monitor Site Maintenance Tasks
  • ConfigMgr 2007 Monitor Site System Summarizer
  • ConfigMgr 2007 Monitor SMS Executive Crash Dumps
  • ConfigMgr 2007 Monitor SMS Inbox
  • ConfigMgr 2007 Monitor SMS Status Messages
  • ConfigMgr 2007 Monitor State Message Summary Tasks
  • ConfigMgr 2007 Service Discovery - Client
  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Site Hierarchy Discovery

ConfigMgr 2007 Monitor SMS Status Messages

Configuration Manager 2007 的许多问题都是通过 SMS 状态系统在内部检测和报告的。Configuration Manager 2007 组件会引发与 Configuration Manager 2007 管理员关注的条件有关的状态消息。

状态消息流入 Configuration Manager 2007 站点的数据库，并沿站点层次结构向上流入父站点的数据库。只需查询指定站点的数据库中的 Configuration Manager 2007 状态消息表，即可监视各个站点上的 Configuration Manager 2007 状态系统。

已经选择了一组能向 Configuration Manager 2007 管理员反映最关键事件的状态消息进行监视。当在数据库中找到其中某个消息时，将生成警报。

此脚本执行以下任务：

  • 检查它是否在无代理托管模式下运行。如果是在无代理托管模式下运行，脚本将退出，不执行任何进一步的操作。
  • 初始化全局变量。
  • 打开 ConfigMgr 2007 Monitor SMS Status Messages.VarSet 文件，并从中读取为要监视的每个配置管理器站点数据库处理的最后一条状态消息的 RecordID。
  • 处理本地计算机上每个 Configuration Manager 2007 站点数据库中找到的状态消息。
  • 对于要监视的 Configuration Manager 2007 站点数据库，将已处理的最后一条状态消息的 RecordID 写入 ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet 文件，并关闭此文件。

ConfigMgr 2007 Monitor SMS Status Messages 脚本将引发事件，并将事件 ID 设置为所报告的 SMS 状态消息的 ID。下表描述了所引发的事件的格式。

由 ConfigMgr 2007 Monitor SMS Status Messages 脚本引发的事件的格式

参数 | 描述
EventType | 可为“Success”、“Error”、“Warning”或“Information”，具体取决于 SMS 状态消息的严重性
EventNumber | SMS 状态消息 ID
Category | ConfigMgr 站点代码
LoggingDomain | 计算机的资源域
LoggingComputer | 计算机的 NetBIOS 名称
Parameter1 | 计算机的 NetBIOS 名称
Parameter2 | ConfigMgr 模块名称，例如 ConfigMgr 服务器
Parameter3 | ConfigMgr 组件名称
Parameter4 | SMS 消息 ID
Parameter5 | Win32 错误代码
Parameter6 | 父级或顶级站点代码
Parameter7 | SMS 状态消息表中状态消息的 RecordID
描述 | “A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database.”

ConfigMgr 2007 Monitor SMS Status Messages 脚本还通过 ID 号为 1102 的状态消息来报告脚本错误：

EventType= Warning

EventNumber= 1102

Description = The script ConfigMgr 2007 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error.The error message will contain the text “Failed to <ErrorDescription>.”

所有 ConfigMgr 2007 状态消息监视事件规则都以短语“ConfigMgr 2007 状态:”开头，并且与 ConfigMgr 站点数据库服务器类关联。

  • ConfigMgr 2007 状态:消息监视

“ConfigMgr 2007 状态:消息监视每 30 分钟启动一次脚本，于以下时间同步：00:02”。此规则的“知识”属性页上提供了摘要信息。

注意
ConfigMgr 2007 状态:如果所监视的表中包含大量历史数据，则运行消息监视将需要很长时间。对于此查询，最佳做法是保持将状态消息除外，以确保该查询不会运行太长时间。

  • ConfigMgr 2007 状态:脚本错误

“ConfigMgr 2007 状态:脚本错误”监视可能发生的任何脚本错误事件并在事件发生时发出警报。只有编号为 1102 的脚本错误事件才会报告所有脚本错误。此规则的“知识”属性页上提供了解决警报的相关信息。

  • ConfigMgr 2007 状态: <status message name>

“ConfigMgr 2007 状态:<status message name>”监视特定状态消息事件并在事件发生时发出警报。此规则的“知识”属性页上提供了解决警报的相关信息。

所有警报都带有以下格式的事件描述，其中 $Description$ 是事件描述：

$Logging Computer$ - "Rule Name".$Description$

ConfigMgr 2007 Monitor SMS Status Messages.VarSet 文件用于保留为站点处理的最后一条状态消息的 RecordID。VarSet 文件位于 TMP 环境变量所指定的文件夹中。它是一个 Tab 分隔的文件，格式如下：

复制代码
LastRecordID_DBNameRecordID#

例如，RecordID 为 477860 的 LastRecordID_SMS_FLA 表示名为 SMS_FLA 的站点数据库中处理的最后一条状态消息的 RecordID 为 477860。

从以前的版本升级管理包时，ConfigMgr 2007 Monitor SMS Status Messages.VarSet 文件中可能会包括以下内容：

复制代码
LastRecordID476743
LastRecordID_SMS_FLA477860

第一行不包含数据库名称，它指示以前的状态消息监视版本，该版本不支持监视多个数据库。第二行则包含数据库名称 SMS_FLA，表示当前版本的状态消息监视功能支持监视多个数据库。

不会利用第一行数据执行任何操作，因为在有多个站点数据库的情况下，难以确定该数据对应的是哪一个数据库。VarSet 文件中没有删除第一行数据，这是因为可以利用它来评估新的更改，并确保在升级后状态消息监视从正确的 RecordID 开始。在 Configuration Manager 2007 中，访问站点数据库的所有脚本都将从站点服务器运行，以便为 SQL 群集提供支持。这是与 SMS 2003 的不同之处。在 SMS 2003 中，脚本总是从 SQL Server 的本地位置运行的。因此，Configuration Manager 2007 站点数据库服务器的实例与 Microsoft Configuration Manager Site Servers 的已发现实例相同。

ConfigMgr 2007 Monitor Site System Summarizer

站点系统摘要生成器

站点系统状态摘要生成器是 SMS Executive 服务的一个组件线程，它保留所有已定义 Configuration Manager 2007 站点系统的状态。默认情况下，它每小时正点轮询一次，以检查当前状态。此轮询间隔是在 Configuration Manager 2007 站点控制文件中定义的。建议不要更改轮询间隔。状态信息保存在 Configuration Manager 2007 站点数据库的某个表中。

站点系统 DownSince 状态

当站点系统状态摘要生成器在一个轮询间隔时间内无法联系某一站点系统时，即假定该站点系统停机。可能有下列原因导致这一情况：

  • 站点系统未开机、未连接到网络或者不能正常运行。
  • 因为没有连接可用，所以 ConfigMgr 2007 站点系统状态摘要生成器未能进行连接。
  • ConfigMgr 2007 站点系统状态摘要生成器没有足够的访问权限来连接到站点系统。
  • 出现网络问题，使 ConfigMgr 2007 站点系统状态摘要生成器无法连接到站点系统。
  • 站点系统已被永久停用。

DownSince 值是 Summarizer_SiteSystem 站点数据库表中的一列。

存在以下约束：

  • 站点系统摘要生成器轮询间隔为 1 小时。此间隔为站点系统状态摘要生成器轮询所有站点系统留下了充分的时间。出于性能方面的考虑，不能更改此间隔。摘要生成器的超时间隔由站点控制文件中的“Startup Schedule”属性控制，而不由“Wakeup Interval”属性控制。这意味着更改“Wakeup Interval”属性的默认值 60 是无效的。此外，更改“Startup Schedule”也无效。默认情况下，该属性设置为每 60 分钟。站点系统状态摘要生成器每小时正点轮询一次站点系统，无论“Startup Schedule”的设置如何都是如此。
  • 只有连续出现两个“ConfigMgr 2007 站点系统摘要生成器:站点系统可能停机”事件时，才会引发警报。这样设计是为了考虑网络临时中断因素。
  • 在 Configuration Manager 2007 不可用的原因中，有许多是站点系统状态摘要生成器监视不到的。例如，如果 SMS 服务未运行或 Configuration Manager 2007 站点数据库不可用（如当 SQL Server 服务停止时），则站点系统状态摘要生成器不会认为配置管理器不可用。
  • 站点系统状态摘要生成器将计算机上承载的每个站点对象和站点系统角色的当前“DownSince”状态写入数据库的“站点系统状态摘要生成器”表中。

站点系统状态摘要生成器监视脚本检查“站点系统状态摘要生成器”表中的每个站点系统角色。如果某个站点系统被标记为停机，该脚本将引发事件。随后将根据该事件生成警报。多个角色可以生成多个警报。

除了 Configuration Manager 2007 分发点之外，每个 Configuration Manager 2007 服务器角色都能在默认情况下创建两个 Configuration Manager 2007 服务器角色，一个用于特定角色，另一个用于 Configuration Manager 2007 组件服务器。例如，在站点系统同时承载一个服务器定位器点和一个报告点的情况下，如果服务器脱机时间超过 2 个小时（两个站点系统状态摘要生成器轮询间隔），站点系统状态摘要生成器会将这两个角色及其配置管理器组件服务器角色标记为停机。

但是，对于这 2 小时内的每个轮询间隔，只会引发三个警报，一个用于每个服务器角色，一个用于承载这两个服务器角色的物理组件服务器。

  • 默认值设为计划 60 分钟（偏离正点 10 分钟），因此 ConfigMgr 2007 Monitor Site System Summarizer 脚本将在站点系统状态摘要生成器轮询间隔（1 小时）开始之后 10 分钟运行。如果摘要生成器完成运行周期所用时间超过 10 分钟，则应适当增加定时事件提供程序的偏差。否则，将错过最新的站点系统状态消息。

ConfigMgr 2007 Monitor SMS Executive Crash Dumps 脚本

此脚本执行下列操作：

  • 确定目标计算机是否在无代理模式下运行。如果是在无代理模式下运行，脚本将退出，不执行进一步的操作。此脚本使用一个本地 VarSet 文件保存变量，因此，必须在运行 SMS Executive 服务的所有目标计算机上安装 Operations Manager 2007 代理。
  • 打开 TMP 环境变量所指定的路径下的本地 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 文件，并将其中的内容读取到集合中。如果该文件不存在，不会引发脚本错误事件。如果该文件存在但无法打开，则会引发脚本错误事件，并显示包含以下文本的消息：

Failed to load script variables.

  • 检查在上次执行检查之后是否发生了新的故障转储。如果发生了新的故障转储，脚本将引发事件，以报告这次新的故障转储。为引发脚本错误事件，脚本将执行以下操作：
    • 从注册表中 SMS Identification 注册表项下的注册表值“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory”获取 ConfigMgr 安装目录。如果无法获得路径，脚本将引发脚本错误事件消息并退出，消息文本如下：

Failed to read registry value.

  • 通过在检索到的配置管理器安装目录之后附加“\Logs\CrashDumps”，构建 CrashDumps 目录的完整路径。
  • 检查 CrashDumps 目录是否存在。如果不存在，该脚本将退出，不执行进一步的操作。
  • 如果 CrashDump 目录存在，它将从 VarSet 集合中获取故障转储文件夹的最新创建日期。
  • 检查是否创建了新的故障转储，并且只对最新的故障转储执行操作。为确定哪一个是最新的，将使用所保存的上一次故障转储的文件夹创建日期（如果可用）。日期和时间的比较是基于文件夹的创建日期（精确到秒）。
  • 如果发生了新的故障转储，或是第一次运行此脚本，脚本将记录并创建事件 1710，指定新的故障转储文件夹和路径。脚本将故障转储的文件夹创建日期保存到 VarSet 集合中。
  • 将 VarSet 集合中的内容写入本地 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 文件，并关闭此文件。如果此文件不存在，则创建此文件。如果未设置 VarSet 变量，则此文件中不包含其相关条目。如果在写入文件时发生错误，将引发脚本错误事件消息，消息文本如下：Failed to save script variables.

ConfigMgr 2007 Monitoring SMS Executive Crash Dump 事件

ConfigMgr 2007 Monitor SMS Executive Crash Dumps 脚本通过事件 1710 报告发生了故障，如下所述：

EventType = Error

EventNumber = 1710

Category = SMS Site Code

Description = SMS Executive in site “XXX” has crashed.有关详细信息，请参阅 <Drive> <ConfigMgr 安装路径>\Logs\CrashDumps\NewFolder 下的故障转储信息。

ConfigMgr 2007 Monitoring SMS Executive Crash Dumps 脚本错误事件

“SMS 2003 Monitor SMS Executive Crash Dumps”脚本通过事件 1102 报告运行时脚本错误。

EventType = Warning

EventNumber = 1102

Description = The script “SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps:Monitoring SMS Executive encountered a runtime error.CrLf “Failed to <Message>." ErrorString

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的视图

Configuration Manager 2007 管理包提供以下通用视图：

  • 警报
  • 计算机状态
  • 事件
  • 站点层次结构图
  • 站点层次结构状态
  • 站点状态
  • 任务状态
  • 和以下类别视图文件夹
  • 常规
  • 性能

常规

  • 最近 72 小时内来自中央站点服务器的警报
  • 最近 72 小时内的新警报

性能视图

可以逐一配置视图，以显示特定计算机的数据。可以通过单独选择所需计算机的计数器来简化图表。

积压\管理点服务器

  • 最近 48 小时内的 DDR 积压
  • 最近 48 小时内的文件收集积压
  • 最近 48 小时内的硬件清单积压
  • 最近 48 小时内的发件箱 ddr.box 积压
  • 最近 48 小时内的发件箱 distmgr.box 积压
  • 最近 48 小时内的发件箱 hinv.box 积压
  • 最近 48 小时内的发件箱 rdr.box 积压
  • 最近 48 小时内的发件箱 sinv.box 积压
  • 最近 48 小时内的发件箱 stat.box 积压
  • 最近 48 小时内的发件箱 statemsg.box 积压
  • 最近 48 小时内的发件箱 swm.box 积压
  • 最近 48 小时内的中继积压
  • 最近 48 小时内的软件清单积压
  • 最近 48 小时内的状态积压

积压\PXE 服务点服务器

  • 最近 24 小时内未处理的数据库请求数

积压\基于 SMS Executive 的服务器

  • 最近 48 小时内的发件箱 stat.box 积压
  • 最近 48 小时内的发件箱 statemsg.box 积压

积压\站点服务器

  • 最近 48 小时内的 DDR 积压
  • 最近 48 小时内的硬件清单积压
  • 最近 48 小时内的收件箱 auth/dataldr.box 积压
  • 最近 48 小时内的收件箱 auth/ddm.box 积压
  • 最近 48 小时内的收件箱 auth/sinv.box 积压
  • 最近 48 小时内的收件箱 auth/statesys.box 积压
  • 最近 48 小时内的收件箱 ciamgr.box 积压
  • 最近 48 小时内的收件箱 ciamgr.box/RETRY.box 积压
  • 最近 48 小时内的收件箱 compsumm.box/repl 积压
  • 最近 48 小时内的收件箱 dataldr.box 积压
  • 最近 48 小时内的收件箱 ddm.box 积压
  • 最近 48 小时内的收件箱 despoolr.box/receive 积压
  • 最近 48 小时内的收件箱 objmgr.box/INCOMING 积压
  • 最近 48 小时内的收件箱 objmgr.box/INCOMING/Retry 积压
  • 最近 48 小时内的收件箱 offermgr.box/INCOMING 积压
  • 最近 48 小时内的收件箱 offersum.box/repl 积压
  • 最近 48 小时内的收件箱 schedule.box/outboxes/LAN 积压
  • 最近 48 小时内的收件箱 schedule.box/requests 积压
  • 最近 48 小时内的收件箱 sinv.box 积压
  • 最近 48 小时内的收件箱 sitestat.box/repl 积压
  • 最近 48 小时内的收件箱 statmgr.box/statmsgs 积压
  • 最近 48 小时内的收件箱 swmproc.box/usage 积压
  • 最近 48 小时内的收件箱 WOLCMGR.box 积压
  • 最近 48 小时内的收件箱 WOLCMGR.box/data 积压
  • 最近 48 小时内的计划程序作业积压
  • 最近 48 小时内的计划程序发送请求积压
  • 最近 48 小时内的软件清单积压
  • 最近 48 小时内的 SWM 积压
  • 最近 48 小时内挂起的 WOL 请求总数

条件\状态迁移点服务器

  • 最近 1 小时内的可用磁盘空间总量

条件\系统健康验证程序服务器

  • 最近 24 小时内的无效修补程序 Cookie 数
  • 最近 24 小时内缺少的修补程序 Cookie 数
  • 最近 24 小时内的新修补程序 Cookie 数
  • 最近 24 小时内的空修补程序 Cookie 数
  • 最近 24 小时内的旧修补程序 Cookie 数
  • 最近 24 小时内相同的修补程序 Cookie 数
  • 最近 24 小时内未安装的修补程序数
  • 最近 24 小时内禁用的 SMS NAP 客户端代理数
  • 最近 24 小时内的 SoH 过期绝对日期数
  • 最近 24 小时内的 SoH 过期 TTL 数

常规\<服务器类型>

下列视图可用于管理点服务器、PXE 服务点服务器、站点服务器、软件更新点服务器、状态迁移点服务器和系统健康验证程序服务器。

  • 最近 48 小时内的逻辑磁盘使用情况
  • 最近 48 小时内的内存使用情况
  • 最近 48 小时内的处理器使用情况

处理速率

  • *最近 24 小时内 ConfigMgr 2007 管理点服务器上的所有消息处理速率
  • *最近 24 小时内 ConfigMgr 2007 管理点服务器上的所有报告处理速率
  • *最近 24 小时内 ConfigMgr 2007 站点服务器上的所有报告处理速率

处理速率\管理点服务器

  • 最近 24 小时内每秒 DDR 数
  • 最近 24 小时每秒 DM 数据库连接尝试次数
  • 最近 24 小时内每秒 DM DDR 数
  • 最近 24 小时内每秒 DM 发现转换请求数
  • 最近 24 小时内每秒 DM DP 位置数
  • 最近 24 小时内每秒 DM 硬件清单转换请求数
  • 最近 24 小时内每秒 DM HINV 数
  • 最近 24 小时内每秒 DM ISAPI 请求数
  • 最近 24 小时内每秒 DM 计算机设置请求数
  • 最近 24 小时内每秒 DM 数据包版本请求数
  • 最近 24 小时内每秒 DM SINV 数
  • 最近 24 小时内每秒 DM 软件策略正文请求数
  • 最近 24 小时内每秒 DM 软件策略 ID 请求数
  • 最近 24 小时内每秒 DM 状态数
  • 最近 24 小时内每秒 DM 设置请求总数
  • 最近 24 小时内每秒 DP 位置数
  • 最近 24 小时内每秒获取 SDM 数据包失败的请求数
  • 最近 24 小时内每秒获取 SDM 数据包的请求数
  • 最近 24 小时内每秒获取验证请求数
  • 最近 24 小时内每秒获取策略请求数
  • 最近 24 小时内每秒 HINV 数
  • 最近 24 小时内每秒 ISAPI 请求数
  • 最近 24 小时内每秒 MP 位置数
  • 最近 24 小时内发件箱 ddr.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 ddr.box 文件复制故障总数
  • 最近 24 小时内发件箱 ddr.box 已复制的文件总数
  • 最近 24 小时内发件箱 distmgr.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 distmgr.box 文件复制故障总数
  • 最近 24 小时内发件箱 distmgr.box 已复制的文件总数
  • 最近 24 小时内发件箱 hinv.box 每分钟复制的文件数
  • 最近 24 小时内发件箱 hinv.box 的文件复制故障总数
  • 最近 24 小时内发件箱 hinv.box 已复制的文件总数
  • 最近 24 小时内发件箱 rdr.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 rdr.box 文件复制故障总数
  • 最近 24 小时内发件箱 rdr.box 已复制的文件总数
  • 最近 24 小时内发件箱 sinv.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 sinv.box 文件复制故障总数
  • 最近 24 小时内发件箱 sinv.box 已复制的文件总数
  • 最近 24 小时内发件箱 stat.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 stat.box 文件复制故障总数
  • 最近 24 小时内发件箱 stat.box 已复制的文件总数
  • 最近 24 小时内发件箱 statemsg.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 statemsg.box 文件复制故障总数
  • 最近 24 小时内发件箱 statemsg.box 已复制的文件总数
  • 最近 24 小时内发件箱 swm.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 swm.box 文件复制故障总数
  • 最近 24 小时内发件箱 swm.box 已复制的文件总数
  • 最近 24 小时内每秒 PA 请求数
  • 最近 24 小时内每秒中继报告数
  • 最近 24 小时内的服务器可用性 DMP 请求的平均延迟时间
  • 最近 24 小时内的服务器可用性 DMP 失败请求数
  • 最近 24 小时内的服务器可用性 DMP 成功请求数
  • 最近 24 小时内的服务器可用性 DMP 请求总数
  • 最近 24 小时内的服务器可用性 MP 成功请求数：
  • 最近 24 小时内的服务器可用性 MP 请求总数
  • 最近 24 小时内每秒 SINV 数
  • 最近 24 小时内每秒执行的 SP 数
  • 最近 24 小时内每秒处理的状态消息数
  • 最近 24 小时内已拒绝的状态消息数：
  • 最近 24 小时内每秒状态数
  • 最近 24 小时内的 DDR 总数
  • 最近 24 小时内的 DM DDR 总数
  • 最近 24 小时内的 DM HINV 总数
  • 最近 24 小时内分发的 DM ISAPI 请求总数
  • DM ISAPI 请求总数：最近 24 小时内收到的请求总数
  • 最近 24 小时内的 DM SINV 总数
  • 最近 24 小时内的 DM 状态总数
  • 最近 24 小时内获取 SDM 数据包失败的请求总数
  • 最近 24 小时内的获取 SDM 数据包请求总数
  • 最近 24 小时内的 HINV 总数
  • 最近 24 小时内的中继报告总数
  • 最近 24 小时内的 SINV 总数
  • 最近 24 小时内已处理的状态消息总数
  • 最近 24 小时内的状态总数

处理速率\PXE 服务点服务器

  • 最近 24 小时内处理的数据库请求数
  • 最近 24 小时内每秒处理的数据库请求数
  • 最近 24 小时内已处理的 DHCP 发现请求数
  • 最近 24 小时内每秒处理的 DHCP 发现请求数
  • 最近 24 小时内已处理的 PXE 请求数
  • 最近 24 小时内每秒处理的 PXE 请求数
  • 最近 24 小时内的服务器可用性 PSP 请求的平均延迟时间
  • 最近 24 小时内的服务器可用性 PSP 失败请求数
  • 最近 24 小时内的服务器可用性 PSP 成功请求数
  • 最近 24 小时内的服务器可用性 PSP 请求总数
  • 最近 24 小时内的失败请求总数
  • 最近 24 小时内的请求总数
  • 最近 24 小时内每秒的请求总数

处理速率\基于 SMS Executive 的服务器

  • 最近 24 小时内发件箱 stat.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 stat.box 文件复制故障总数
  • 最近 24 小时内发件箱 stat.box 已复制的文件总数
  • 最近 24 小时内发件箱 statemsg.box 每分钟复制的文件数
  • 最近 24 小时内的发件箱 statemsg.box 文件复制故障总数
  • 最近 24 小时内发件箱 statemsg.box 已复制的文件数

处理速率\站点服务器

  • 最近 24 小时内平均每分钟写入的更新数
  • 最近 24 小时内每分钟 DDR 数
  • 最近 24 小时内每分钟 HINV 数
  • 最近 24 小时内每秒的 WOL 数据包数
  • 最近 24 小时内每分钟 SINV 数
  • 最近 24 小时内的状态消息文件处理线程数
  • 最近 24 小时内每分钟处理的状态消息文件数
  • 最近 24 小时内每分钟处理的状态消息记录数
  • 最近 24 小时内每分钟状态数
  • 最近 24 小时内每分钟 SWM 数
  • 最近 24 小时内处理的错误状态消息文件总数
  • 最近 24 小时内的 DDR 总数
  • 最近 24 小时内的 HINV 总数
  • 最近 24 小时内已处理的无效状态消息记录总数
  • 最近 24 小时内失败的 WOL 数据包总数
  • 最近 24 小时内发送的 WOL 数据包总数
  • 最近 24 小时内的 SINV 总数
  • 最近 24 小时内已处理的状态消息文件总数
  • 最近 24 小时内已放弃的状态消息记录总数
  • 最近 24 小时内已处理的状态消息记录总数
  • 最近 24 小时内的状态总数
  • 最近 24 小时内的 SWM 总数
  • 最近 24 小时内已写入的更新总数

处理速率\状态迁移点服务器

  • 最近 1 小时内当前处于已完成保存状态的客户端数
  • 最近 1 小时内当前处于正在还原状态的客户端数
  • 最近 1 小时内当前处于正在保存状态的客户端数
  • 最近 24 小时内的服务器可用性 SMP 请求的平均延迟时间
  • 最近 24 小时内的服务器可用性 SMP 失败请求数
  • 最近 24 小时内的服务器可用性 SMP 成功请求数
  • 最近 24 小时内的服务器可用性 SMP 请求总数
  • 最近 1 小时内已拒绝的客户端总数

处理速率\系统健康验证程序服务器

  • 最近 24 小时内每秒 SoH 请求数
  • 最近 24 小时内的 SoH 请求总数
  • 最近 24 小时内的 SoH 客户端脆弱性响应数
  • 最近 24 小时内的 SoH 相容响应数
  • 最近 24 小时内的 SoH 故障响应数
  • 最近 24 小时内的 SoH 不相容响应数
  • 最近 24 小时内的 SoH 服务器脆弱性响应数
  • 最近 24 小时内的 SoH 未知响应数

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的图表
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的图表

Configuration Manager 2007 管理包提供了 Configuration Manager 2007 站点层次结构的图表。其中显示了站点服务器和站点系统及其相互关系，并带有上下文相关的信息。此拓扑图包括逻辑数据（例如层次结构和站点）和物理数据（例如站点服务器和站点系统）。由于 Configuration Manager 2007 层次结构可能很复杂，因此这些图表具有以下要求：

  • 必须在所有中央站点服务器及其 SMS 提供程序上本地安装 Operations Manager 2007 代理。
  • 以自上而下的方式在所有主站点服务器上本地安装 Operations Manager 2007 代理，具体取决于所需的配置管理器站点层次结构的层数。
  • 必须为已安装的每个 Operations Manager 2007 代理启用代理。
  • 使用 Configuration Manager 2007 管理员控制台为要由 Operations Manager 发现的每个服务器输入完全限定的域名 (FQDN)。
  • 配置管理器服务器必须已被发现，并显示在配置管理器管理员控制台的“所有系统”集合中。
  • 服务发现必须发现 ConfigMgr 服务器实例。

发现是通过下面两个脚本执行的。

  • ConfigMgr 2007 Service Discovery - Server
  • ConfigMgr 2007 Site Hierarchy Discovery

Service Discovery 将发现 ConfigMgr 服务器类的实例。Site Hierarchy Discovery 将发现以下内容：

  • 站点 - 基于每个站点，从主站点的提供程序发现中央站点、主站点和辅助站点
  • 站点与站点的关系
  • 站点内的服务器
  • 站点服务器与站点系统之间的关系

发现数据可部分显示在该图表中，并可通过对象属性来更完全地进行显示。此外，可以采用 .jpeg、.bmp 或 .png 文件的格式保存这些图表。

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的报告


Configuration Manager 2007 管理包的报告

Configuration Manager 2007 管理包中提供本节所介绍的各种报告。报告是必须单独安装的可选 Operations Manager 组件。有关部署报告服务器的详细信息，请参阅有关 Operations Manager 2007 产品的网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该链接可能指向英文页面）。

Configuration Manager 2007 报告

Configuration Manager 2007 管理包涵盖下面三种类型的报告：

  • 可用性
  • 配置
  • 性能

报告针对通过对象选取器选择的组或对象。所有报告均已链接，以便利用 Operations Manager 2007 报告功能。报告有七种导出格式可供选择。

可用性报告

Configuration Manager 2007 管理包中的可用性报告针对 ConfigMgr 服务器类及其监视器。可以通过在报告的对象选取器中选择“Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup group”或“Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class”对象来执行这些报告。

服务器可用性

此报告基于特定服务器上所有实体的聚合健康状况，并将包含 System.Health.EntityState 的可用性健康状况。

分发点可用性

此报告基于分发点的可用性健康状况，并使用来自 DP 运行状况监视器的信息。

管理点可用性

此报告基于管理点的可用性健康状况，并使用来自 MP 运行状况监视器的信息。

PXE 服务点可用性

此报告基于 PXE 服务点的可用性健康状况，并使用来自 PSP 运行状况监视器的信息。

站点服务器可用性

此报告基于站点服务器的可用性健康状况，并使用来自 SS 运行状况监视器的信息。

软件更新点可用性

此报告基于软件更新点的可用性健康状况，并使用来自 SUP 运行状况监视器的信息。

系统健康验证程序可用性

此报告基于系统健康验证程序点的可用性健康状况，并使用来自 SHV 运行状况监视器的信息。

配置报告

随 Configuration Manager 2007 管理包提供了一种配置报告，即 Configuration Manager 2007 服务器自定义配置报告。此报告显示了以下 ConfigMgr 服务器类属性：

  • 版本（Configuration Manager 2007 产品版本）
  • 站点系统类型（站点系统类型、服务器类型、数据库服务器类型）
  • 组件（站点服务器、服务器定位器点、分发点、管理点、报告点、数据库服务器、提供程序、发送程序、客户端访问点）
  • 站点代码（SMS 站点代码）
  • 服务器类型（中央、主、辅助站点服务器）
  • 名称（NetBIOS 名称）
  • 数据库服务器类型（站点数据库服务器）

可以通过在该报告的对象选取器中选择“Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup group”或“Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class”对象来执行此报告。

性能报告

性能报告主要是根据配置管理器服务器角色或对象（即管理点或数据发现记录）来分组的。这些组可以进一步分成原始（总计）和速率（每秒或每分钟）类型，以便值可以在报告中进行相应调整。

这些报告及其性能计数器采用便于分析趋势和进行故障排除的方式进行组织。对象报告通常在调查配置管理器基础结构中的问题时使用，而服务器角色报告将用于解决管理点上的问题。

Configuration Manager 2007 服务器性能组报告

要运行下列报告，请在对象选取器目标组中选择“Microsoft.SystemCenter.ConfigurationManager.2007.ServerPerformanceGroup”。

ConfigMgr 2007 数据发现记录速率性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的数据发现记录 (DDR) 处理速率。

ConfigMgr 2007 性能测量:站点服务器 DDR 处理速率 | 每分钟处理的 DDR 数
ConfigMgr 2007 性能测量:MP DDR 管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:DMP DDR 处理速率 | 每秒生成的发现报告数

ConfigMgr 2007 数据发现记录原始性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 DDR 积压和已处理总计。

ConfigMgr 2007 性能测量:站点服务器 DDR 积压 | 总计显示已排入队列的数据发现记录速率
ConfigMgr 2007 性能测量:已处理的站点服务器 DDR 总数 | 每秒报告总数
ConfigMgr 2007 性能测量:DMP DDR 处理速率 | 每秒生成的发现报告数

ConfigMgr 2007 设备管理点原始性能

此报告显示 Configuration Manager 2007 设备管理点服务器角色的已处理总计。

ConfigMgr 2007 性能测量:已处理的 DMP DDR 总数 | 生成的发现报告总数
ConfigMgr 2007 性能测量:已处理的 DMP HINV 总数 | 生成的硬件清单报告总数
ConfigMgr 2007 性能测量:已处理的 DMP SINV 总数 | 生成的软件清单报告总数
ConfigMgr 2007 性能测量:已处理的 DMP 状态消息总数 | 发出的状态消息总数
ConfigMgr 2007 性能测量:已分发的 DMP ISAPI 请求总数 | 已分发的消息总数
ConfigMgr 2007 性能测量:收到的 DMP ISAPI 请求总数 | 收到的消息总数

ConfigMgr 2007 设备管理点速率性能

此报告显示 Configuration Manager 2007 设备管理点服务器角色的处理速率。

ConfigMgr 2007 性能测量:DMP 设置请求速率 | 每秒 DMP 设置请求数
ConfigMgr 2007 性能测量:DMP 计算机设置请求速率 | 每秒计算机设置请求数
ConfigMgr 2007 性能测量:DMP 软件策略 ID 请求速率 | 每秒软件策略 ID 请求数
ConfigMgr 2007 性能测量:DMP 软件策略正文请求速率 | 每秒软件策略正文请求数
ConfigMgr 2007 性能测量:DMP 数据包版本请求速率 | 每秒数据包版本请求数
ConfigMgr 2007 性能测量:DMP 发现转换请求速率 | 每秒发现转换请求数
ConfigMgr 2007 性能测量:DMP 硬件清单转换请求速率 | 每秒硬件清单转换请求数
ConfigMgr 2007 性能测量:DMP 数据库连接尝试速率 | 每秒数据库连接尝试次数
ConfigMgr 2007 性能测量:DMP DDR 处理速率 | 每秒生成的发现报告数
ConfigMgr 2007 性能测量:DMP HINV 处理速率 | 每秒生成的硬件清单报告数
ConfigMgr 2007 性能测量:DMP DP 位置请求处理速率 | 每秒生成的位置请求数
ConfigMgr 2007 性能测量:DMP ISAPI 消息处理速率 | 每秒分发的消息数
ConfigMgr 2007 性能测量:DMP SINV 处理速率 | 每秒生成的软件清单报告数
ConfigMgr 2007 性能测量:DMP 状态处理速率 | 每秒引发的状态消息数

ConfigMgr 2007 硬件清单速率性能

此报告显示所有适用 SMS 服务器角色的硬件清单 (HINV) 处理速率。

ConfigMgr 2007 性能测量:站点服务器 HINV 处理速率 | 每分钟处理的 MIF 数
ConfigMgr 2007 性能测量:MP HINV 管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP HINV 重试管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:DMP HINV 处理速率 | 每秒生成的硬件清单报告数

ConfigMgr 2007 硬件清单原始性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 HINV 积压和已处理总计。

ConfigMgr 2007 性能测量:站点服务器 HINV 积压 | 排入队列的 MIF 总数
ConfigMgr 2007 性能测量:已处理的站点服务器 HINV 总数 | 已处理的 MIF 总数
ConfigMgr 2007 性能测量:MP HINV 积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP HINV 管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:已处理的 DMP HINV 总数 | 生成的硬件清单报告总数

ConfigMgr 2007 管理点速率性能

此报告显示 Configuration Manager 2007 管理点服务器角色的处理速率。

ConfigMgr 2007 性能测量:MP 位置管理器(每秒 MP 请求数) | 每秒 MP 请求数
ConfigMgr 2007 性能测量:MP 位置管理器(每秒 DP 请求数) | 每秒 DP 请求数
ConfigMgr 2007 性能测量:MP 获取策略(每秒请求数) | 每秒请求数
ConfigMgr 2007 性能测量:MP 获取验证(每秒请求数) | 每秒请求数
ConfigMgr 2007 性能测量:MP 策略管理器(每秒 PA 请求数) | 每秒 PA 请求数
ConfigMgr 2007 性能测量:MP DAL (每秒执行的 SP 数) | SPs Executed/second
ConfigMgr 2007 性能测量:MP HINV 管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP HINV 重试管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP SINV 管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP SINV 集合文件管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP 中继管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP 状态管理器(每秒事件总数) | 每秒事件总数

ConfigMgr 2007 管理点原始性能

此报告显示 Configuration Manager 2007 管理点服务器角色的积压和已处理总计。

ConfigMgr 2007 性能测量:MP DDR 积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP DDR 管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:MP HINV 积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP HINV 管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:MP 文件收集积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP SINV 积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP SINV 管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:MP 中继管理器积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP 中继管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:MP 状态积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP 状态管理器(事件总数) | 事件总数

ConfigMgr 2007 服务器系统资源性能

此报告显示 Configuration Manager 2007 服务器角色的系统资源使用情况。

ConfigMgr 2007 性能测量:内存 - 使用中的已提交字节百分比 % | 使用中的已提交字节
ConfigMgr 2007 性能测量:分页文件 - 使用百分比 % | 使用百分比 %
ConfigMgr 2007 性能测量:处理器 - 处理器时间百分比 % (_总计) | 处理器时间百分比 %
ConfigMgr 2007 性能测量:进程 - 处理器时间百分比 % (smsexec) | 处理器时间百分比 %
ConfigMgr 2007 性能测量:进程 - 处理器时间百分比 % (ccmexec) | 处理器时间百分比 %
ConfigMgr 2007 性能测量:系统 - 系统运行时间 | 系统运行时间

ConfigMgr 2007 站点服务器原始性能

此报告显示 Configuration Manager 2007 站点服务器角色的处理速率。

ConfigMgr 2007 性能测量:站点服务器计划程序作业积压 | 作业数
ConfigMgr 2007 性能测量:站点服务器计划程序发送请求积压 | 发送请求数
ConfigMgr 2007 性能测量:SMS Executive 线程状态运行线程数总计 | 运行线程数
ConfigMgr 2007 性能测量:站点服务器 DDR 积压 | 排入队列的 DDR 总数
ConfigMgr 2007 性能测量:已处理的站点服务器 DDR 总数 | 已处理的 DDR 总数
ConfigMgr 2007 性能测量:站点服务器 HINV 积压 | 排入队列的 MIF 总数
ConfigMgr 2007 性能测量:已处理的站点服务器 HINV 总数 | 已处理的 MIF 总数
ConfigMgr 2007 性能测量:站点服务器 SINV 积压 | 排入队列的 SINV 总数
ConfigMgr 2007 性能测量:已处理的站点服务器 SINV 总数 | 已处理的 SINV 总数
ConfigMgr 2007 性能测量:站点服务器 SWM 积压 | 排入队列的 SWM 用法文件总数
ConfigMgr 2007 性能测量:已处理的站点服务器 SWM 总数 | 已处理的 SWM 用法文件总数
ConfigMgr 2007 性能测量:已处理的站点服务器状态消息总数 | 收到的消息
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统消息记录总数 | 已处理的消息记录总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统无效消息记录总数 | 已处理的无效消息记录总数
ConfigMgr 2007 性能测量:已放弃的 SMS 状态系统消息记录总数 | 已放弃的消息记录总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统消息文件总数 | 已处理的消息文件总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统错误消息文件总数 | 已处理的错误消息文件总数
ConfigMgr 2007 性能测量:SMS 状态系统消息文件处理线程数 | 消息文件处理线程数
ConfigMgr 2007 性能测量:已发送的 SMS LAN 唤醒通信管理器数据包总数 | 已发送的数据包总数
ConfigMgr 2007 性能测量:失败的 SMS LAN 唤醒通信管理器数据包总数 | 失败的数据包总数
ConfigMgr 2007 性能测量:挂起的 SMS LAN 唤醒通信管理器请求总数 | 挂起的请求总数

ConfigMgr 2007 站点服务器速率性能

此报告显示 Configuration Manager 2007 站点服务器角色的处理速率。

ConfigMgr 2007 性能测量:站点服务器 HINV 处理速率 | 每分钟处理的 MIF 数
ConfigMgr 2007 性能测量:站点服务器 SINV 处理速率 | 每分钟处理的 SINV 数
ConfigMgr 2007 性能测量:站点服务器 SWM 处理速率 | 每分钟处理的 SWM 用法记录数
ConfigMgr 2007 性能测量:站点服务器状态处理速率 | 每秒处理的消息数
ConfigMgr 2007 性能测量:SMS 状态系统消息记录处理速率 | 处理速率
ConfigMgr 2007 性能测量:SMS 状态系统消息文件处理速率 | 每分钟处理的消息文件数
ConfigMgr 2007 性能测量:每秒的 SMS LAN 唤醒通信管理器数据包数 | 每秒的数据包数

ConfigMgr 2007 软件清单速率性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的软件清单 (SINV) 处理速率。

ConfigMgr 2007 性能测量:站点服务器 SINV 处理速率 | 每分钟处理的 SINV 数
ConfigMgr 2007 性能测量:MP Sinv 管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:MP Sinv 集合文件管理器(每秒报告总数) | 每秒报告总数
ConfigMgr 2007 性能测量:DMP SINV 处理速率 | 每秒生成的软件清单报告数

ConfigMgr 2007 软件清单原始性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 SINV 积压和已处理总计。

ConfigMgr 2007 性能测量:站点服务器 SINV 积压 | 排入队列的 SINV 总数
ConfigMgr 2007 性能测量:已处理的站点服务器 SINV 总数 | 已处理的 SINV 总数
ConfigMgr 2007 性能测量:MP 文件收集积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP SINV 积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP Sinv 管理器(报告总数) | 报告总数
ConfigMgr 2007 性能测量:已处理的 DMP SINV 总数 | 生成的软件清单报告总数

ConfigMgr 2007 软件计数原始性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的软件计数 (SWM) 积压和已处理总计。

ConfigMgr 2007 性能测量:站点服务器 SWM 积压 | 排入队列的 SWM 用法文件总数
ConfigMgr 2007 性能测量:已处理的站点服务器 SWM 总数 | 已处理的 SWM 用法记录总数
ConfigMgr 2007 性能测量:MP 中继管理器积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP 中继管理器(报告总数) | 报告总数

ConfigMgr 2007 软件计数速率性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 SWM 处理速率。

ConfigMgr 2007 性能测量:站点服务器 SWM 处理速率 | 每分钟处理的 SWM 用法记录数
ConfigMgr 2007 性能测量:MP 中继管理器(每秒报告总数) | 每秒报告总数

ConfigMgr 2007 状态消息原始性能

此报告显示所有适用 SMS 服务器角色的 Configuration Manager 2007 状态消息积压和已处理总计。

ConfigMgr 2007 性能测量:已处理的 SMS 状态系统消息记录总数 | 已处理的消息记录总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统无效消息记录总数 | 已处理的无效消息记录总数
ConfigMgr 2007 性能测量:已放弃的 SMS 状态系统消息记录总数 | 已放弃的消息记录总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统消息文件总数 | 已处理的消息文件总数
ConfigMgr 2007 性能测量:已处理的 SMS 状态系统错误消息记录总数 | 已处理的错误消息文件总数
ConfigMgr 2007 性能测量:SMS 状态系统消息文件处理线程数 | 消息文件处理线程数
ConfigMgr 2007 性能测量:已处理的 MP 状态消息数 | 消息总数
ConfigMgr 2007 性能测量:已拒绝的 MP 状态消息数 | 已拒绝的消息数

ConfigMgr 2007 状态消息速率性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 SMS 状态消息处理速率。

ConfigMgr 2007 性能测量:SMS 状态系统消息记录处理速率 | 每分钟处理的消息记录数
ConfigMgr 2007 性能测量:SMS 状态系统消息文件处理速率 | 每分钟处理的消息文件数
ConfigMgr 2007 性能测量:MP 状态消息处理速率 | 每秒的消息数

ConfigMgr 2007 状态消息原始性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 SMS 状态消息积压和已处理总计。

ConfigMgr 2007 性能测量:已处理的站点服务器状态消息总数 | 收到的消息
ConfigMgr 2007 性能测量:MP 状态积压 | 排入队列的消息数
ConfigMgr 2007 性能测量:MP 状态管理器(事件总数) | 事件总数
ConfigMgr 2007 性能测量:已处理的 DMP 状态消息总数 | 发出的状态消息总数

ConfigMgr 2007 状态消息速率性能

此报告显示所有适用 Configuration Manager 2007 服务器角色的 SMS 状态消息处理速率。

ConfigMgr 2007 性能测量:站点服务器状态处理速率 | 每秒处理的消息数
ConfigMgr 2007 性能测量:MP 状态管理器(每秒事件总数) | 每秒事件总数
ConfigMgr 2007 性能测量:DMP 状态处理速率 | 每秒引发的状态消息数

ConfigMgr 2007 支持服务器角色性能

此报告显示支持 Configuration Manager 2007 服务器角色的服务的性能。

ConfigMgr 2007 性能测量:Web 服务(每秒 ISAPI 扩展请求数)

每秒 ISAPI 扩展请求数

另请参阅

概念

Configuration Manager 2007 管理包的其他资源
Configuration Manager 2007 管理包的站点和组件
Configuration Manager 2007 管理包的计算机组
Configuration Manager 2007 管理包的安装类
Configuration Manager 2007 管理包的脚本
Configuration Manager 2007 管理包的视图
Configuration Manager 2007 管理包的图表